Fix: let automake handle CLEAN and DIST
[babeltrace.git] / tests / lib / Makefile.am
index 6a58cb8d0dcc40f696b8bc9cf6171a1451730156..12febed4c17f1c99fd69732ee1352ac39fe074fd 100644 (file)
@@ -26,9 +26,9 @@ test_seek_SOURCES = test_seek.c
 test_bitfield_SOURCES = test_bitfield.c
 test_ctf_writer_SOURCES = test_ctf_writer.c
 
-SCRIPT_LIST = test_seek_big_trace \
-       test_seek_empty_packet \
-       test_ctf_writer_complete
+check_SCRIPTS = test_seek_big_trace \
+               test_seek_empty_packet
+SCRIPT_LIST = test_ctf_writer_complete
 
 if ENABLE_DEBUGINFO
 test_dwarf_LDFLAGS = -static
@@ -37,8 +37,14 @@ test_dwarf_LDADD = $(LIBTAP) \
        $(top_builddir)/lib/libdebuginfo.la
 test_dwarf_SOURCES = test_dwarf.c
 
-noinst_PROGRAMS += test_dwarf
-SCRIPT_LIST += test_dwarf_complete
+test_bin_info_LDFLAGS = -static
+test_bin_info_LDADD = $(LIBTAP) \
+       $(top_builddir)/lib/libbabeltrace.la \
+       $(top_builddir)/lib/libdebuginfo.la
+test_bin_info_SOURCES = test_bin_info.c
+
+noinst_PROGRAMS += test_dwarf test_bin_info
+SCRIPT_LIST += test_dwarf_complete test_bin_info_complete
 endif
 
 dist_noinst_SCRIPTS = $(SCRIPT_LIST)
This page took 0.023114 seconds and 4 git commands to generate.