Fix: let automake handle CLEAN and DIST
[babeltrace.git] / tests / lib / Makefile.am
index 9bb5060520d56d4a966c2a45440f4d8706544e2d..12febed4c17f1c99fd69732ee1352ac39fe074fd 100644 (file)
@@ -26,11 +26,9 @@ test_seek_SOURCES = test_seek.c
 test_bitfield_SOURCES = test_bitfield.c
 test_ctf_writer_SOURCES = test_ctf_writer.c
 
-SCRIPT_LIST = test_seek_big_trace \
-       test_seek_empty_packet \
-       test_ctf_writer_complete
-EXTRA_DIST = test_seek_big_trace.in test_seek_empty_packet.in
-CLEANFILES= test_seek_big_trace test_seek_empty_packet
+check_SCRIPTS = test_seek_big_trace \
+               test_seek_empty_packet
+SCRIPT_LIST = test_ctf_writer_complete
 
 if ENABLE_DEBUGINFO
 test_dwarf_LDFLAGS = -static
@@ -39,14 +37,14 @@ test_dwarf_LDADD = $(LIBTAP) \
        $(top_builddir)/lib/libdebuginfo.la
 test_dwarf_SOURCES = test_dwarf.c
 
-test_so_info_LDFLAGS = -static
-test_so_info_LDADD = $(LIBTAP) \
+test_bin_info_LDFLAGS = -static
+test_bin_info_LDADD = $(LIBTAP) \
        $(top_builddir)/lib/libbabeltrace.la \
        $(top_builddir)/lib/libdebuginfo.la
-test_so_info_SOURCES = test_so_info.c
+test_bin_info_SOURCES = test_bin_info.c
 
-noinst_PROGRAMS += test_dwarf test_so_info
-SCRIPT_LIST += test_dwarf_complete test_so_info_complete
+noinst_PROGRAMS += test_dwarf test_bin_info
+SCRIPT_LIST += test_dwarf_complete test_bin_info_complete
 endif
 
 dist_noinst_SCRIPTS = $(SCRIPT_LIST)
This page took 0.022763 seconds and 4 git commands to generate.