Tests: add unit tests for bt_dwarf
[babeltrace.git] / tests / lib / Makefile.am
index f1efac690ee76cfe7a9e1e8990a5d6872d450e04..13df71575e94d27251efba095c912eb622b1efd4 100644 (file)
@@ -46,6 +46,17 @@ SCRIPT_LIST = test_seek_big_trace \
        test_ctf_writer_complete
 EXTRA_DIST = test_seek_big_trace.in test_seek_empty_packet.in
 
+if ENABLE_DEBUGINFO
+test_dwarf_LDFLAGS = -static
+test_dwarf_LDADD = $(LIBTAP) \
+       $(top_builddir)/lib/libbabeltrace.la \
+       $(top_builddir)/lib/libdebuginfo.la
+test_dwarf_SOURCES = test_dwarf.c
+
+noinst_PROGRAMS += test_dwarf
+SCRIPT_LIST += test_dwarf_complete
+endif
+
 dist_noinst_SCRIPTS = $(SCRIPT_LIST)
 
 all-local:
This page took 0.028221 seconds and 4 git commands to generate.