tests: Move ctf-writer to it's own directory
[babeltrace.git] / tests / lib / Makefile.am
index b2b34642e07fea6c54d8beced4bf5faa73f9a581..14912a17c4400f632560474c420b5d08dc0d3c6e 100644 (file)
@@ -1,46 +1,35 @@
-SUBDIRS = ctf-ir ctf-writer
+SUBDIRS =
 
 AM_CPPFLAGS += -I$(top_srcdir)/tests/utils
 
-LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
+COMMON_TEST_LDADD = \
+       $(top_builddir)/tests/utils/tap/libtap.la \
+       $(top_builddir)/tests/utils/libtestcommon.la
 
-libtestcommon_la_SOURCES = common.c common.h
-noinst_LTLIBRARIES = libtestcommon.la
+test_bitfield_LDADD = $(COMMON_TEST_LDADD)
 
-# -Wl,--no-as-needed is needed for recent gold linker who seems to think
-# it knows better and considers libraries with constructors having
-# side-effects as dead code.
-COMMON_TEST_LDADD = $(LIBTAP) $(builddir)/libtestcommon.la \
-       $(top_builddir)/lib/libbabeltrace.la
+test_bt_values_LDADD = $(COMMON_TEST_LDADD) \
+       $(top_builddir)/src/lib/libbabeltrace2.la
 
-test_bitfield_LDADD = $(LIBTAP) $(builddir)/libtestcommon.la
+test_trace_ir_ref_LDADD = $(COMMON_TEST_LDADD) \
+       $(top_builddir)/src/lib/libbabeltrace2.la \
+       $(top_builddir)/src/ctf-writer/libbabeltrace2-ctf-writer.la
 
-test_ctf_writer_LDADD = $(COMMON_TEST_LDADD)
+test_graph_topo_LDADD = $(COMMON_TEST_LDADD) \
+       $(top_builddir)/src/lib/libbabeltrace2.la
 
-test_bt_values_LDADD = $(COMMON_TEST_LDADD)
-
-test_ctf_ir_ref_LDADD = $(COMMON_TEST_LDADD)
-
-test_graph_topo_LDADD = $(COMMON_TEST_LDADD)
-
-test_bt_notification_iterator_LDADD = $(COMMON_TEST_LDADD)
-
-noinst_PROGRAMS = test_bitfield test_ctf_writer test_bt_values \
-       test_ctf_ir_ref test_graph_topo test_bt_notification_iterator
+noinst_PROGRAMS = test_bitfield test_bt_values \
+       test_trace_ir_ref test_graph_topo
 
 test_bitfield_SOURCES = test_bitfield.c
-test_ctf_writer_SOURCES = test_ctf_writer.c
 test_bt_values_SOURCES = test_bt_values.c
-test_ctf_ir_ref_SOURCES = test_ctf_ir_ref.c
+test_trace_ir_ref_SOURCES = test_trace_ir_ref.c
 test_graph_topo_SOURCES = test_graph_topo.c
-test_bt_notification_iterator_SOURCES = test_bt_notification_iterator.c
-
-check_SCRIPTS = test_ctf_writer_complete
 
 if !ENABLE_BUILT_IN_PLUGINS
 noinst_PROGRAMS += test_plugin
-test_plugin_LDADD = $(COMMON_TEST_LDADD)
+test_plugin_LDADD = $(COMMON_TEST_LDADD) \
+       $(top_builddir)/src/lib/libbabeltrace2.la
 test_plugin_SOURCES = test_plugin.c
-check_SCRIPTS += test_plugin_complete
 SUBDIRS += test-plugin-plugins
 endif
This page took 0.024166 seconds and 4 git commands to generate.