Fix out-of-tree tests: seek tests can't find traces
[babeltrace.git] / tests / lib / Makefile.am
index 6a58cb8d0dcc40f696b8bc9cf6171a1451730156..1f3f5c9e6d1e77b57b6e8d8d48d972a97cfaf765 100644 (file)
@@ -29,6 +29,7 @@ test_ctf_writer_SOURCES = test_ctf_writer.c
 SCRIPT_LIST = test_seek_big_trace \
        test_seek_empty_packet \
        test_ctf_writer_complete
+EXTRA_DIST = test_seek_big_trace.in test_seek_empty_packet.in
 
 if ENABLE_DEBUGINFO
 test_dwarf_LDFLAGS = -static
@@ -37,8 +38,14 @@ test_dwarf_LDADD = $(LIBTAP) \
        $(top_builddir)/lib/libdebuginfo.la
 test_dwarf_SOURCES = test_dwarf.c
 
-noinst_PROGRAMS += test_dwarf
-SCRIPT_LIST += test_dwarf_complete
+test_so_info_LDFLAGS = -static
+test_so_info_LDADD = $(LIBTAP) \
+       $(top_builddir)/lib/libbabeltrace.la \
+       $(top_builddir)/lib/libdebuginfo.la
+test_so_info_SOURCES = test_so_info.c
+
+noinst_PROGRAMS += test_dwarf test_so_info
+SCRIPT_LIST += test_dwarf_complete test_so_info_complete
 endif
 
 dist_noinst_SCRIPTS = $(SCRIPT_LIST)
This page took 0.022952 seconds and 4 git commands to generate.