Fix out-of-tree tests: seek tests can't find traces
[babeltrace.git] / tests / lib / Makefile.am
index 7c96e4ab0b2c0448964feb5e063bca4c51f8f394..1f3f5c9e6d1e77b57b6e8d8d48d972a97cfaf765 100644 (file)
@@ -9,7 +9,7 @@ libtestcommon_a_SOURCES = common.c common.h
 # -Wl,--no-as-needed is needed for recent gold linker who seems to think
 # it knows better and considers libraries with constructors having
 # side-effects as dead code.
 # -Wl,--no-as-needed is needed for recent gold linker who seems to think
 # it knows better and considers libraries with constructors having
 # side-effects as dead code.
-test_seek_LDFLAGS = -Wl,--no-as-needed
+test_seek_LDFLAGS = $(LD_NO_AS_NEEDED)
 test_seek_LDADD = $(LIBTAP) libtestcommon.a \
        $(top_builddir)/lib/libbabeltrace.la \
        $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
 test_seek_LDADD = $(LIBTAP) libtestcommon.a \
        $(top_builddir)/lib/libbabeltrace.la \
        $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
@@ -29,6 +29,24 @@ test_ctf_writer_SOURCES = test_ctf_writer.c
 SCRIPT_LIST = test_seek_big_trace \
        test_seek_empty_packet \
        test_ctf_writer_complete
 SCRIPT_LIST = test_seek_big_trace \
        test_seek_empty_packet \
        test_ctf_writer_complete
+EXTRA_DIST = test_seek_big_trace.in test_seek_empty_packet.in
+
+if ENABLE_DEBUGINFO
+test_dwarf_LDFLAGS = -static
+test_dwarf_LDADD = $(LIBTAP) \
+       $(top_builddir)/lib/libbabeltrace.la \
+       $(top_builddir)/lib/libdebuginfo.la
+test_dwarf_SOURCES = test_dwarf.c
+
+test_so_info_LDFLAGS = -static
+test_so_info_LDADD = $(LIBTAP) \
+       $(top_builddir)/lib/libbabeltrace.la \
+       $(top_builddir)/lib/libdebuginfo.la
+test_so_info_SOURCES = test_so_info.c
+
+noinst_PROGRAMS += test_dwarf test_so_info
+SCRIPT_LIST += test_dwarf_complete test_so_info_complete
+endif
 
 dist_noinst_SCRIPTS = $(SCRIPT_LIST)
 
 
 dist_noinst_SCRIPTS = $(SCRIPT_LIST)
 
This page took 0.022842 seconds and 4 git commands to generate.