Fix out-of-tree tests: seek tests can't find traces
[babeltrace.git] / tests / lib / Makefile.am
index f7e32c2b70f9aba6c507821a3fe77efe4da9aa5f..1f3f5c9e6d1e77b57b6e8d8d48d972a97cfaf765 100644 (file)
@@ -1,18 +1,65 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
+AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include -I$(top_srcdir)/tests/utils
 
 noinst_LIBRARIES = libtestcommon.a
 
-libtestcommon_a_SOURCES = tap.c tap.h common.c common.h
+LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
 
-test_seeks_LDADD = libtestcommon.a \
+libtestcommon_a_SOURCES = common.c common.h
+
+# -Wl,--no-as-needed is needed for recent gold linker who seems to think
+# it knows better and considers libraries with constructors having
+# side-effects as dead code.
+test_seek_LDFLAGS = $(LD_NO_AS_NEEDED)
+test_seek_LDADD = $(LIBTAP) libtestcommon.a \
+       $(top_builddir)/lib/libbabeltrace.la \
+       $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
+
+test_bitfield_LDADD = $(LIBTAP) libtestcommon.a
+
+test_ctf_writer_LDADD = $(LIBTAP) \
        $(top_builddir)/lib/libbabeltrace.la \
        $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
 
-noinst_PROGRAMS = test-seeks
+noinst_PROGRAMS = test_seek test_bitfield test_ctf_writer
+
+test_seek_SOURCES = test_seek.c
+test_bitfield_SOURCES = test_bitfield.c
+test_ctf_writer_SOURCES = test_ctf_writer.c
+
+SCRIPT_LIST = test_seek_big_trace \
+       test_seek_empty_packet \
+       test_ctf_writer_complete
+EXTRA_DIST = test_seek_big_trace.in test_seek_empty_packet.in
+
+if ENABLE_DEBUGINFO
+test_dwarf_LDFLAGS = -static
+test_dwarf_LDADD = $(LIBTAP) \
+       $(top_builddir)/lib/libbabeltrace.la \
+       $(top_builddir)/lib/libdebuginfo.la
+test_dwarf_SOURCES = test_dwarf.c
+
+test_so_info_LDFLAGS = -static
+test_so_info_LDADD = $(LIBTAP) \
+       $(top_builddir)/lib/libbabeltrace.la \
+       $(top_builddir)/lib/libdebuginfo.la
+test_so_info_SOURCES = test_so_info.c
+
+noinst_PROGRAMS += test_dwarf test_so_info
+SCRIPT_LIST += test_dwarf_complete test_so_info_complete
+endif
 
-test_seeks_SOURCES = test-seeks.c
+dist_noinst_SCRIPTS = $(SCRIPT_LIST)
 
-EXTRA_DIST = README.tap
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
 
-check-am:
-       ./runall.sh
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.023352 seconds and 4 git commands to generate.