Tests: add unit tests for bt_dwarf
[babeltrace.git] / tests / lib / Makefile.am
index 8c46acb533746f7cf85ce96029ff7ccd300f12c8..6a58cb8d0dcc40f696b8bc9cf6171a1451730156 100644 (file)
@@ -30,6 +30,17 @@ SCRIPT_LIST = test_seek_big_trace \
        test_seek_empty_packet \
        test_ctf_writer_complete
 
+if ENABLE_DEBUGINFO
+test_dwarf_LDFLAGS = -static
+test_dwarf_LDADD = $(LIBTAP) \
+       $(top_builddir)/lib/libbabeltrace.la \
+       $(top_builddir)/lib/libdebuginfo.la
+test_dwarf_SOURCES = test_dwarf.c
+
+noinst_PROGRAMS += test_dwarf
+SCRIPT_LIST += test_dwarf_complete
+endif
+
 dist_noinst_SCRIPTS = $(SCRIPT_LIST)
 
 all-local:
This page took 0.022849 seconds and 4 git commands to generate.