Fix: Remove test_seek_empty_packet and test_seek_big_trace from SCRIPT_LIST
[babeltrace.git] / tests / lib / Makefile.am
index 1f3f5c9e6d1e77b57b6e8d8d48d972a97cfaf765..6e48271b319e0d8d1876e3661fbcd8f710b15ce6 100644 (file)
@@ -26,10 +26,11 @@ test_seek_SOURCES = test_seek.c
 test_bitfield_SOURCES = test_bitfield.c
 test_ctf_writer_SOURCES = test_ctf_writer.c
 
-SCRIPT_LIST = test_seek_big_trace \
-       test_seek_empty_packet \
-       test_ctf_writer_complete
+check_SCRIPTS = test_seek_big_trace \
+               test_seek_empty_packet
+SCRIPT_LIST = test_ctf_writer_complete
 EXTRA_DIST = test_seek_big_trace.in test_seek_empty_packet.in
+CLEANFILES= test_seek_big_trace test_seek_empty_packet
 
 if ENABLE_DEBUGINFO
 test_dwarf_LDFLAGS = -static
@@ -38,14 +39,14 @@ test_dwarf_LDADD = $(LIBTAP) \
        $(top_builddir)/lib/libdebuginfo.la
 test_dwarf_SOURCES = test_dwarf.c
 
-test_so_info_LDFLAGS = -static
-test_so_info_LDADD = $(LIBTAP) \
+test_bin_info_LDFLAGS = -static
+test_bin_info_LDADD = $(LIBTAP) \
        $(top_builddir)/lib/libbabeltrace.la \
        $(top_builddir)/lib/libdebuginfo.la
-test_so_info_SOURCES = test_so_info.c
+test_bin_info_SOURCES = test_bin_info.c
 
-noinst_PROGRAMS += test_dwarf test_so_info
-SCRIPT_LIST += test_dwarf_complete test_so_info_complete
+noinst_PROGRAMS += test_dwarf test_bin_info
+SCRIPT_LIST += test_dwarf_complete test_bin_info_complete
 endif
 
 dist_noinst_SCRIPTS = $(SCRIPT_LIST)
This page took 0.026399 seconds and 4 git commands to generate.