Add bt_graph_add_component(), make bt_component_create() internal
[babeltrace.git] / tests / lib / Makefile.am
index 060ff29d4734a09c868ef325c4e810caf8f4a721..6f816f4ba9b080d3539db048afdcb1f4850b0483 100644 (file)
@@ -73,3 +73,29 @@ check_SCRIPTS = test_ctf_writer_complete \
 #noinst_PROGRAMS += test_dwarf test_bin_info
 #check_SCRIPTS += test_dwarf_complete test_bin_info_complete
 #endif
+
+LOG_DRIVER_FLAGS='--merge'
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) $(top_srcdir)/config/tap-driver.sh
+
+TESTS = test_bitfield \
+       test_ctf_writer_complete \
+       test_bt_values \
+       test_ctf_ir_ref \
+       test_bt_ctf_field_type_validation \
+       test_ir_visit \
+       test_bt_notification_heap \
+       test_plugin_complete \
+       test_graph_topo \
+       test_cc_prio_map \
+       test_bt_notification_iterator
+
+if ENABLE_DEBUG_INFO
+TESTS += test_dwarf_complete \
+       test_bin_info_complete
+endif
+
+if USE_PYTHON
+TESTS +=
+       writer/test_ctf_writer_no_packet_context.py \
+       writer/test_ctf_writer_empty_packet.py
+endif
This page took 0.023481 seconds and 4 git commands to generate.