Add bt_graph_add_component(), make bt_component_create() internal
[babeltrace.git] / tests / lib / Makefile.am
index 4af9d6b37a0c4acbe4854bda744f5ca31b4d59c6..6f816f4ba9b080d3539db048afdcb1f4850b0483 100644 (file)
@@ -26,8 +26,6 @@ test_bt_ctf_field_type_validation_LDADD = $(COMMON_TEST_LDADD)
 
 test_ir_visit_LDADD = $(COMMON_TEST_LDADD)
 
-test_trace_listener_LDADD = $(COMMON_TEST_LDADD)
-
 test_bt_notification_heap_LDADD = $(COMMON_TEST_LDADD)
 
 test_plugin_LDADD = $(COMMON_TEST_LDADD)
@@ -36,10 +34,12 @@ test_graph_topo_LDADD = $(COMMON_TEST_LDADD)
 
 test_cc_prio_map_LDADD = $(COMMON_TEST_LDADD)
 
+test_bt_notification_iterator_LDADD = $(COMMON_TEST_LDADD)
+
 noinst_PROGRAMS = test_bitfield test_ctf_writer test_bt_values \
        test_ctf_ir_ref test_bt_ctf_field_type_validation test_ir_visit \
-       test_trace_listener test_bt_notification_heap test_plugin test_graph_topo \
-       test_cc_prio_map
+       test_bt_notification_heap test_plugin test_graph_topo \
+       test_cc_prio_map test_bt_notification_iterator
 
 test_bitfield_SOURCES = test_bitfield.c
 test_ctf_writer_SOURCES = test_ctf_writer.c
@@ -47,11 +47,11 @@ test_bt_values_SOURCES = test_bt_values.c
 test_ctf_ir_ref_SOURCES = test_ctf_ir_ref.c
 test_bt_ctf_field_type_validation_SOURCES = test_bt_ctf_field_type_validation.c
 test_ir_visit_SOURCES = test_ir_visit.c
-test_trace_listener_SOURCES = test_trace_listener.c
 test_bt_notification_heap_SOURCES = test_bt_notification_heap.c
 test_plugin_SOURCES = test_plugin.c
 test_graph_topo_SOURCES = test_graph_topo.c
 test_cc_prio_map_SOURCES = test_cc_prio_map.c
+test_bt_notification_iterator_SOURCES = test_bt_notification_iterator.c
 
 check_SCRIPTS = test_ctf_writer_complete \
                test_plugin_complete
@@ -73,3 +73,29 @@ check_SCRIPTS = test_ctf_writer_complete \
 #noinst_PROGRAMS += test_dwarf test_bin_info
 #check_SCRIPTS += test_dwarf_complete test_bin_info_complete
 #endif
+
+LOG_DRIVER_FLAGS='--merge'
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) $(top_srcdir)/config/tap-driver.sh
+
+TESTS = test_bitfield \
+       test_ctf_writer_complete \
+       test_bt_values \
+       test_ctf_ir_ref \
+       test_bt_ctf_field_type_validation \
+       test_ir_visit \
+       test_bt_notification_heap \
+       test_plugin_complete \
+       test_graph_topo \
+       test_cc_prio_map \
+       test_bt_notification_iterator
+
+if ENABLE_DEBUG_INFO
+TESTS += test_dwarf_complete \
+       test_bin_info_complete
+endif
+
+if USE_PYTHON
+TESTS +=
+       writer/test_ctf_writer_no_packet_context.py \
+       writer/test_ctf_writer_empty_packet.py
+endif
This page took 0.024457 seconds and 4 git commands to generate.