make check VPATH build
[babeltrace.git] / tests / lib / Makefile.am
index 1d6a1925a6fdf7cc9f87c6b2a6b43d0566f37dcd..763b7bc0b9619c25acccc9d9efa39cc285206c56 100644 (file)
@@ -17,4 +17,20 @@ noinst_PROGRAMS = test_seek test_bitfield
 test_seek_SOURCES = test_seek.c
 test_bitfield_SOURCES = test_bitfield.c
 
-dist_noinst_SCRIPTS = test_seek_big_trace test_seek_empty_packet
+SCRIPT_LIST = test_seek_big_trace test_seek_empty_packet
+
+dist_noinst_SCRIPTS = $(SCRIPT_LIST)
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.02286 seconds and 4 git commands to generate.