Port: Add compat for platforms with no MSG_NOSIGNAL or SO_NOSIGPIPE
[babeltrace.git] / tests / lib / Makefile.am
index 849767a77e8a4ae96e6e5899a0191aa888a676c5..7c96e4ab0b2c0448964feb5e063bca4c51f8f394 100644 (file)
@@ -16,12 +16,19 @@ test_seek_LDADD = $(LIBTAP) libtestcommon.a \
 
 test_bitfield_LDADD = $(LIBTAP) libtestcommon.a
 
-noinst_PROGRAMS = test_seek test_bitfield
+test_ctf_writer_LDADD = $(LIBTAP) \
+       $(top_builddir)/lib/libbabeltrace.la \
+       $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
+
+noinst_PROGRAMS = test_seek test_bitfield test_ctf_writer
 
 test_seek_SOURCES = test_seek.c
 test_bitfield_SOURCES = test_bitfield.c
+test_ctf_writer_SOURCES = test_ctf_writer.c
 
-SCRIPT_LIST = test_seek_big_trace test_seek_empty_packet
+SCRIPT_LIST = test_seek_big_trace \
+       test_seek_empty_packet \
+       test_ctf_writer_complete
 
 dist_noinst_SCRIPTS = $(SCRIPT_LIST)
 
This page took 0.022838 seconds and 4 git commands to generate.