Add CTF Writer implementation
[babeltrace.git] / tests / lib / Makefile.am
index a7de0a946b0df10466b8c056fbb132ab29635c95..849767a77e8a4ae96e6e5899a0191aa888a676c5 100644 (file)
@@ -6,6 +6,10 @@ LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
 
 libtestcommon_a_SOURCES = common.c common.h
 
+# -Wl,--no-as-needed is needed for recent gold linker who seems to think
+# it knows better and considers libraries with constructors having
+# side-effects as dead code.
+test_seek_LDFLAGS = -Wl,--no-as-needed
 test_seek_LDADD = $(LIBTAP) libtestcommon.a \
        $(top_builddir)/lib/libbabeltrace.la \
        $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
@@ -17,7 +21,20 @@ noinst_PROGRAMS = test_seek test_bitfield
 test_seek_SOURCES = test_seek.c
 test_bitfield_SOURCES = test_bitfield.c
 
-EXTRA_DIST = runall.sh
+SCRIPT_LIST = test_seek_big_trace test_seek_empty_packet
 
-check-am:
-       ./runall.sh
+dist_noinst_SCRIPTS = $(SCRIPT_LIST)
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
This page took 0.024068 seconds and 4 git commands to generate.