Port: Add support for linkers with no support for 'no-as-needed'
[babeltrace.git] / tests / lib / Makefile.am
index 7c96e4ab0b2c0448964feb5e063bca4c51f8f394..8c46acb533746f7cf85ce96029ff7ccd300f12c8 100644 (file)
@@ -9,7 +9,7 @@ libtestcommon_a_SOURCES = common.c common.h
 # -Wl,--no-as-needed is needed for recent gold linker who seems to think
 # it knows better and considers libraries with constructors having
 # side-effects as dead code.
-test_seek_LDFLAGS = -Wl,--no-as-needed
+test_seek_LDFLAGS = $(LD_NO_AS_NEEDED)
 test_seek_LDADD = $(LIBTAP) libtestcommon.a \
        $(top_builddir)/lib/libbabeltrace.la \
        $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
This page took 0.02265 seconds and 4 git commands to generate.