Port: Add support for linkers with no support for 'no-as-needed'
[babeltrace.git] / tests / lib / Makefile.am
index 849767a77e8a4ae96e6e5899a0191aa888a676c5..8c46acb533746f7cf85ce96029ff7ccd300f12c8 100644 (file)
@@ -9,19 +9,26 @@ libtestcommon_a_SOURCES = common.c common.h
 # -Wl,--no-as-needed is needed for recent gold linker who seems to think
 # it knows better and considers libraries with constructors having
 # side-effects as dead code.
-test_seek_LDFLAGS = -Wl,--no-as-needed
+test_seek_LDFLAGS = $(LD_NO_AS_NEEDED)
 test_seek_LDADD = $(LIBTAP) libtestcommon.a \
        $(top_builddir)/lib/libbabeltrace.la \
        $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
 
 test_bitfield_LDADD = $(LIBTAP) libtestcommon.a
 
-noinst_PROGRAMS = test_seek test_bitfield
+test_ctf_writer_LDADD = $(LIBTAP) \
+       $(top_builddir)/lib/libbabeltrace.la \
+       $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
+
+noinst_PROGRAMS = test_seek test_bitfield test_ctf_writer
 
 test_seek_SOURCES = test_seek.c
 test_bitfield_SOURCES = test_bitfield.c
+test_ctf_writer_SOURCES = test_ctf_writer.c
 
-SCRIPT_LIST = test_seek_big_trace test_seek_empty_packet
+SCRIPT_LIST = test_seek_big_trace \
+       test_seek_empty_packet \
+       test_ctf_writer_complete
 
 dist_noinst_SCRIPTS = $(SCRIPT_LIST)
 
This page took 0.022696 seconds and 4 git commands to generate.