Port: Add support for linkers with no support for 'no-as-needed'
[babeltrace.git] / tests / lib / Makefile.am
index e1aa471ce47b2dc5a68e3b4481f60b59676cc7c8..8c46acb533746f7cf85ce96029ff7ccd300f12c8 100644 (file)
@@ -9,7 +9,7 @@ libtestcommon_a_SOURCES = common.c common.h
 # -Wl,--no-as-needed is needed for recent gold linker who seems to think
 # it knows better and considers libraries with constructors having
 # side-effects as dead code.
-test_seek_LDFLAGS = -Wl,--no-as-needed
+test_seek_LDFLAGS = $(LD_NO_AS_NEEDED)
 test_seek_LDADD = $(LIBTAP) libtestcommon.a \
        $(top_builddir)/lib/libbabeltrace.la \
        $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
@@ -26,7 +26,9 @@ test_seek_SOURCES = test_seek.c
 test_bitfield_SOURCES = test_bitfield.c
 test_ctf_writer_SOURCES = test_ctf_writer.c
 
-SCRIPT_LIST = test_seek_big_trace test_seek_empty_packet
+SCRIPT_LIST = test_seek_big_trace \
+       test_seek_empty_packet \
+       test_ctf_writer_complete
 
 dist_noinst_SCRIPTS = $(SCRIPT_LIST)
 
This page took 0.025126 seconds and 4 git commands to generate.