Tests: add unit tests for so_info
[babeltrace.git] / tests / lib / Makefile.am
index 6a58cb8d0dcc40f696b8bc9cf6171a1451730156..8fe4a15002552e852c290494be638a5b6681df2e 100644 (file)
@@ -37,8 +37,14 @@ test_dwarf_LDADD = $(LIBTAP) \
        $(top_builddir)/lib/libdebuginfo.la
 test_dwarf_SOURCES = test_dwarf.c
 
-noinst_PROGRAMS += test_dwarf
-SCRIPT_LIST += test_dwarf_complete
+test_so_info_LDFLAGS = -static
+test_so_info_LDADD = $(LIBTAP) \
+       $(top_builddir)/lib/libbabeltrace.la \
+       $(top_builddir)/lib/libdebuginfo.la
+test_so_info_SOURCES = test_so_info.c
+
+noinst_PROGRAMS += test_dwarf test_so_info
+SCRIPT_LIST += test_dwarf_complete test_so_info_complete
 endif
 
 dist_noinst_SCRIPTS = $(SCRIPT_LIST)
This page took 0.022915 seconds and 4 git commands to generate.