Use printf_debug/verbose in so-info
[babeltrace.git] / tests / lib / Makefile.am
index 8c46acb533746f7cf85ce96029ff7ccd300f12c8..9bb5060520d56d4a966c2a45440f4d8706544e2d 100644 (file)
@@ -29,6 +29,25 @@ test_ctf_writer_SOURCES = test_ctf_writer.c
 SCRIPT_LIST = test_seek_big_trace \
        test_seek_empty_packet \
        test_ctf_writer_complete
+EXTRA_DIST = test_seek_big_trace.in test_seek_empty_packet.in
+CLEANFILES= test_seek_big_trace test_seek_empty_packet
+
+if ENABLE_DEBUGINFO
+test_dwarf_LDFLAGS = -static
+test_dwarf_LDADD = $(LIBTAP) \
+       $(top_builddir)/lib/libbabeltrace.la \
+       $(top_builddir)/lib/libdebuginfo.la
+test_dwarf_SOURCES = test_dwarf.c
+
+test_so_info_LDFLAGS = -static
+test_so_info_LDADD = $(LIBTAP) \
+       $(top_builddir)/lib/libbabeltrace.la \
+       $(top_builddir)/lib/libdebuginfo.la
+test_so_info_SOURCES = test_so_info.c
+
+noinst_PROGRAMS += test_dwarf test_so_info
+SCRIPT_LIST += test_dwarf_complete test_so_info_complete
+endif
 
 dist_noinst_SCRIPTS = $(SCRIPT_LIST)
 
This page took 0.022928 seconds and 4 git commands to generate.