Tests babeltrace: adapt python tests to use unittest
[babeltrace.git] / tests / lib / Makefile.am
index 1d6a1925a6fdf7cc9f87c6b2a6b43d0566f37dcd..9e20545d124a0f2e5d82c44308391393b6f1416e 100644 (file)
@@ -1,20 +1,60 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include -I$(top_srcdir)/tests/utils
+SUBDIRS=
 
-noinst_LIBRARIES = libtestcommon.a
+AM_CPPFLAGS += -I$(top_srcdir)/tests/utils
 
 LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
 
-libtestcommon_a_SOURCES = common.c common.h
+libtestcommon_la_SOURCES = common.c common.h
+noinst_LTLIBRARIES = libtestcommon.la
 
-test_seek_LDADD = $(LIBTAP) libtestcommon.a \
-       $(top_builddir)/lib/libbabeltrace.la \
-       $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
+# -Wl,--no-as-needed is needed for recent gold linker who seems to think
+# it knows better and considers libraries with constructors having
+# side-effects as dead code.
+COMMON_TEST_LDADD = $(LIBTAP) $(builddir)/libtestcommon.la \
+       $(top_builddir)/lib/libbabeltrace.la
 
-test_bitfield_LDADD = $(LIBTAP) libtestcommon.a
+test_bitfield_LDADD = $(LIBTAP) $(builddir)/libtestcommon.la
 
-noinst_PROGRAMS = test_seek test_bitfield
+test_ctf_writer_LDADD = $(COMMON_TEST_LDADD)
 
-test_seek_SOURCES = test_seek.c
-test_bitfield_SOURCES = test_bitfield.c
+test_bt_values_LDADD = $(COMMON_TEST_LDADD)
+
+test_ctf_ir_ref_LDADD = $(COMMON_TEST_LDADD)
+
+test_bt_ctf_field_type_validation_LDADD = $(COMMON_TEST_LDADD)
+
+test_ir_visit_LDADD = $(COMMON_TEST_LDADD)
+
+test_bt_notification_heap_LDADD = $(COMMON_TEST_LDADD)
 
-dist_noinst_SCRIPTS = test_seek_big_trace test_seek_empty_packet
+test_graph_topo_LDADD = $(COMMON_TEST_LDADD)
+
+test_cc_prio_map_LDADD = $(COMMON_TEST_LDADD)
+
+test_bt_notification_iterator_LDADD = $(COMMON_TEST_LDADD)
+
+noinst_PROGRAMS = test_bitfield test_ctf_writer test_bt_values \
+       test_ctf_ir_ref test_bt_ctf_field_type_validation test_ir_visit \
+       test_bt_notification_heap test_graph_topo \
+       test_cc_prio_map test_bt_notification_iterator
+
+test_bitfield_SOURCES = test_bitfield.c
+test_ctf_writer_SOURCES = test_ctf_writer.c
+test_bt_values_SOURCES = test_bt_values.c
+test_ctf_ir_ref_SOURCES = test_ctf_ir_ref.c
+test_bt_ctf_field_type_validation_SOURCES = test_bt_ctf_field_type_validation.c
+test_ir_visit_SOURCES = test_ir_visit.c
+test_bt_notification_heap_SOURCES = test_bt_notification_heap.c
+test_graph_topo_SOURCES = test_graph_topo.c
+test_cc_prio_map_SOURCES = test_cc_prio_map.c
+test_bt_notification_iterator_SOURCES = test_bt_notification_iterator.c
+
+check_SCRIPTS = test_ctf_writer_complete
+
+if !ENABLE_BUILT_IN_PLUGINS
+noinst_PROGRAMS += test_plugin
+test_plugin_LDADD = $(COMMON_TEST_LDADD)
+test_plugin_SOURCES = test_plugin.c
+check_SCRIPTS += test_plugin_complete
+SUBDIRS += test-plugin-plugins
+endif
This page took 0.024699 seconds and 4 git commands to generate.