Tests babeltrace: adapt python tests to use unittest
[babeltrace.git] / tests / lib / Makefile.am
index 80cf97750eec12b97c94ef547f0980f9a5d61ee4..9e20545d124a0f2e5d82c44308391393b6f1416e 100644 (file)
@@ -1,4 +1,4 @@
-SUBDIRS = writer .
+SUBDIRS=
 
 AM_CPPFLAGS += -I$(top_srcdir)/tests/utils
 
@@ -51,54 +51,10 @@ test_bt_notification_iterator_SOURCES = test_bt_notification_iterator.c
 
 check_SCRIPTS = test_ctf_writer_complete
 
-#FIXME
-#if ENABLE_DEBUG_INFO
-#test_dwarf_LDFLAGS = -static
-#test_dwarf_LDADD = $(LIBTAP) \
-#      $(top_builddir)/lib/libbabeltrace.la \
-#      $(top_builddir)/lib/libdebug-info.la
-#test_dwarf_SOURCES = test_dwarf.c
-
-#test_bin_info_LDFLAGS = -static
-#test_bin_info_LDADD = $(LIBTAP) \
-#      $(top_builddir)/lib/libbabeltrace.la \
-#      $(top_builddir)/lib/libdebug-info.la
-#test_bin_info_SOURCES = test_bin_info.c
-
-#noinst_PROGRAMS += test_dwarf test_bin_info
-#check_SCRIPTS += test_dwarf_complete test_bin_info_complete
-#endif
-
-LOG_DRIVER_FLAGS='--merge'
-LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) $(top_srcdir)/config/tap-driver.sh
-
-TESTS = test_bitfield \
-       test_ctf_writer_complete \
-       test_bt_values \
-       test_ctf_ir_ref \
-       test_bt_ctf_field_type_validation \
-       test_ir_visit \
-       test_bt_notification_heap \
-       test_graph_topo \
-       test_cc_prio_map \
-       test_bt_notification_iterator
-
-if ENABLE_DEBUG_INFO
-TESTS += test_dwarf_complete \
-       test_bin_info_complete
-endif
-
-if USE_PYTHON
-TESTS +=
-       writer/test_ctf_writer_no_packet_context.py \
-       writer/test_ctf_writer_empty_packet.py
-endif
-
-if !BUILT_IN_PLUGINS
+if !ENABLE_BUILT_IN_PLUGINS
 noinst_PROGRAMS += test_plugin
 test_plugin_LDADD = $(COMMON_TEST_LDADD)
 test_plugin_SOURCES = test_plugin.c
-TESTS += test_plugin_complete
 check_SCRIPTS += test_plugin_complete
 SUBDIRS += test-plugin-plugins
 endif
This page took 0.023043 seconds and 4 git commands to generate.