Tests babeltrace: adapt python tests to use unittest
[babeltrace.git] / tests / lib / Makefile.am
index c9c25a998ab06c33ed9eb3a976ac92b095af89ed..9e20545d124a0f2e5d82c44308391393b6f1416e 100644 (file)
@@ -1,6 +1,6 @@
-SUBDIRS = test-plugin-plugins writer .
+SUBDIRS=
 
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include -I$(top_srcdir)/tests/utils
+AM_CPPFLAGS += -I$(top_srcdir)/tests/utils
 
 LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
 
@@ -17,8 +17,7 @@ test_bitfield_LDADD = $(LIBTAP) $(builddir)/libtestcommon.la
 
 test_ctf_writer_LDADD = $(COMMON_TEST_LDADD)
 
-test_bt_values_LDADD = $(LIBTAP) \
-       $(top_builddir)/lib/libbabeltrace.la
+test_bt_values_LDADD = $(COMMON_TEST_LDADD)
 
 test_ctf_ir_ref_LDADD = $(COMMON_TEST_LDADD)
 
@@ -26,20 +25,18 @@ test_bt_ctf_field_type_validation_LDADD = $(COMMON_TEST_LDADD)
 
 test_ir_visit_LDADD = $(COMMON_TEST_LDADD)
 
-test_trace_listener_LDADD = $(COMMON_TEST_LDADD)
-
 test_bt_notification_heap_LDADD = $(COMMON_TEST_LDADD)
 
-test_plugin_LDADD = $(COMMON_TEST_LDADD)
-
 test_graph_topo_LDADD = $(COMMON_TEST_LDADD)
 
 test_cc_prio_map_LDADD = $(COMMON_TEST_LDADD)
 
+test_bt_notification_iterator_LDADD = $(COMMON_TEST_LDADD)
+
 noinst_PROGRAMS = test_bitfield test_ctf_writer test_bt_values \
        test_ctf_ir_ref test_bt_ctf_field_type_validation test_ir_visit \
-       test_trace_listener test_bt_notification_heap test_plugin test_graph_topo \
-       test_cc_prio_map
+       test_bt_notification_heap test_graph_topo \
+       test_cc_prio_map test_bt_notification_iterator
 
 test_bitfield_SOURCES = test_bitfield.c
 test_ctf_writer_SOURCES = test_ctf_writer.c
@@ -47,28 +44,17 @@ test_bt_values_SOURCES = test_bt_values.c
 test_ctf_ir_ref_SOURCES = test_ctf_ir_ref.c
 test_bt_ctf_field_type_validation_SOURCES = test_bt_ctf_field_type_validation.c
 test_ir_visit_SOURCES = test_ir_visit.c
-test_trace_listener_SOURCES = test_trace_listener.c
 test_bt_notification_heap_SOURCES = test_bt_notification_heap.c
-test_plugin_SOURCES = test_plugin.c
 test_graph_topo_SOURCES = test_graph_topo.c
 test_cc_prio_map_SOURCES = test_cc_prio_map.c
+test_bt_notification_iterator_SOURCES = test_bt_notification_iterator.c
 
-check_SCRIPTS = test_ctf_writer_complete \
-               test_plugin_complete
-
-if ENABLE_DEBUG_INFO
-test_dwarf_LDFLAGS = -static
-test_dwarf_LDADD = $(LIBTAP) \
-       $(top_builddir)/lib/libbabeltrace.la \
-       $(top_builddir)/lib/libdebug-info.la
-test_dwarf_SOURCES = test_dwarf.c
-
-test_bin_info_LDFLAGS = -static
-test_bin_info_LDADD = $(LIBTAP) \
-       $(top_builddir)/lib/libbabeltrace.la \
-       $(top_builddir)/lib/libdebug-info.la
-test_bin_info_SOURCES = test_bin_info.c
+check_SCRIPTS = test_ctf_writer_complete
 
-noinst_PROGRAMS += test_dwarf test_bin_info
-check_SCRIPTS += test_dwarf_complete test_bin_info_complete
+if !ENABLE_BUILT_IN_PLUGINS
+noinst_PROGRAMS += test_plugin
+test_plugin_LDADD = $(COMMON_TEST_LDADD)
+test_plugin_SOURCES = test_plugin.c
+check_SCRIPTS += test_plugin_complete
+SUBDIRS += test-plugin-plugins
 endif
This page took 0.024116 seconds and 4 git commands to generate.