Fix build with BUILT_IN_PLUGINS=1
[babeltrace.git] / tests / lib / Makefile.am
index 6f816f4ba9b080d3539db048afdcb1f4850b0483..ca5ffc3f6b4d46552e7ba24317a42a47266beed5 100644 (file)
@@ -1,4 +1,4 @@
-SUBDIRS = test-plugin-plugins writer .
+SUBDIRS = writer .
 
 AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include -I$(top_srcdir)/tests/utils
 
@@ -17,8 +17,7 @@ test_bitfield_LDADD = $(LIBTAP) $(builddir)/libtestcommon.la
 
 test_ctf_writer_LDADD = $(COMMON_TEST_LDADD)
 
-test_bt_values_LDADD = $(LIBTAP) \
-       $(top_builddir)/lib/libbabeltrace.la
+test_bt_values_LDADD = $(COMMON_TEST_LDADD)
 
 test_ctf_ir_ref_LDADD = $(COMMON_TEST_LDADD)
 
@@ -28,8 +27,6 @@ test_ir_visit_LDADD = $(COMMON_TEST_LDADD)
 
 test_bt_notification_heap_LDADD = $(COMMON_TEST_LDADD)
 
-test_plugin_LDADD = $(COMMON_TEST_LDADD)
-
 test_graph_topo_LDADD = $(COMMON_TEST_LDADD)
 
 test_cc_prio_map_LDADD = $(COMMON_TEST_LDADD)
@@ -38,7 +35,7 @@ test_bt_notification_iterator_LDADD = $(COMMON_TEST_LDADD)
 
 noinst_PROGRAMS = test_bitfield test_ctf_writer test_bt_values \
        test_ctf_ir_ref test_bt_ctf_field_type_validation test_ir_visit \
-       test_bt_notification_heap test_plugin test_graph_topo \
+       test_bt_notification_heap test_graph_topo \
        test_cc_prio_map test_bt_notification_iterator
 
 test_bitfield_SOURCES = test_bitfield.c
@@ -48,13 +45,11 @@ test_ctf_ir_ref_SOURCES = test_ctf_ir_ref.c
 test_bt_ctf_field_type_validation_SOURCES = test_bt_ctf_field_type_validation.c
 test_ir_visit_SOURCES = test_ir_visit.c
 test_bt_notification_heap_SOURCES = test_bt_notification_heap.c
-test_plugin_SOURCES = test_plugin.c
 test_graph_topo_SOURCES = test_graph_topo.c
 test_cc_prio_map_SOURCES = test_cc_prio_map.c
 test_bt_notification_iterator_SOURCES = test_bt_notification_iterator.c
 
-check_SCRIPTS = test_ctf_writer_complete \
-               test_plugin_complete
+check_SCRIPTS = test_ctf_writer_complete
 
 #FIXME
 #if ENABLE_DEBUG_INFO
@@ -84,7 +79,6 @@ TESTS = test_bitfield \
        test_bt_ctf_field_type_validation \
        test_ir_visit \
        test_bt_notification_heap \
-       test_plugin_complete \
        test_graph_topo \
        test_cc_prio_map \
        test_bt_notification_iterator
@@ -99,3 +93,12 @@ TESTS +=
        writer/test_ctf_writer_no_packet_context.py \
        writer/test_ctf_writer_empty_packet.py
 endif
+
+if !BUILT_IN_PLUGINS
+noinst_PROGRAMS += test_plugin
+test_plugin_LDADD = $(COMMON_TEST_LDADD)
+test_plugin_SOURCES = test_plugin.c
+TESTS += test_plugin_complete
+check_SCRIPTS += test_plugin_complete
+SUBDIRS += test-plugin-plugins
+endif
This page took 0.023642 seconds and 4 git commands to generate.