Add bt_plugin test
[babeltrace.git] / tests / lib / Makefile.am
index 8fb1910861f11da2b655f6a1b5a163a7d5ced8ee..d02d14960d615d3127e4841e0047476efd6b69e1 100644 (file)
@@ -1,4 +1,4 @@
-SUBDIRS = writer
+SUBDIRS = test-plugin-plugins writer .
 
 AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include -I$(top_srcdir)/tests/utils
 
@@ -34,9 +34,11 @@ test_trace_listener_LDADD = $(COMMON_TEST_LDADD)
 
 test_bt_notification_heap_LDADD = $(COMMON_TEST_LDADD)
 
+test_plugin_LDADD = $(COMMON_TEST_LDADD)
+
 noinst_PROGRAMS = test_seek test_bitfield test_ctf_writer test_bt_values \
        test_ctf_ir_ref test_bt_ctf_field_type_validation test_ir_visit \
-       test_trace_listener test_bt_notification_heap
+       test_trace_listener test_bt_notification_heap test_plugin
 
 test_seek_SOURCES = test_seek.c
 test_bitfield_SOURCES = test_bitfield.c
@@ -47,10 +49,12 @@ test_bt_ctf_field_type_validation_SOURCES = test_bt_ctf_field_type_validation.c
 test_ir_visit_SOURCES = test_ir_visit.c
 test_trace_listener_SOURCES = test_trace_listener.c
 test_bt_notification_heap_SOURCES = test_bt_notification_heap.c
+test_plugin_SOURCES = test_plugin.c
 
 check_SCRIPTS = test_seek_big_trace \
                test_seek_empty_packet \
-               test_ctf_writer_complete
+               test_ctf_writer_complete \
+               test_plugin_complete
 
 if ENABLE_DEBUG_INFO
 test_dwarf_LDFLAGS = -static
This page took 0.024928 seconds and 4 git commands to generate.