Tests: Split lib tests in multiple standalone test scripts
[babeltrace.git] / tests / lib / Makefile.am
index 01831de3dfb86452bba6c3e39bf652750b37c56d..dac6a73eb876c82b95f3a7fc48c23fea3755f739 100644 (file)
@@ -1,21 +1,20 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
+AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include -I$(top_srcdir)/tests/utils
 
 noinst_LIBRARIES = libtestcommon.a
 
-libtestcommon_a_SOURCES = tap.c tap.h common.c common.h
+LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
 
-test_seeks_LDADD = libtestcommon.a \
+libtestcommon_a_SOURCES = common.c common.h
+
+test_seek_LDADD = $(LIBTAP) libtestcommon.a \
        $(top_builddir)/lib/libbabeltrace.la \
        $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
 
-test_bitfield_LDADD = libtestcommon.a
-
-noinst_PROGRAMS = test-seeks test-bitfield
+test_bitfield_LDADD = $(LIBTAP) libtestcommon.a
 
-test_seeks_SOURCES = test-seeks.c
-test_bitfield_SOURCES = test-bitfield.c
+noinst_PROGRAMS = test_seek test_bitfield
 
-EXTRA_DIST = README.tap runall.sh
+test_seek_SOURCES = test_seek.c
+test_bitfield_SOURCES = test_bitfield.c
 
-check-am:
-       ./runall.sh
+EXTRA_DIST = test_seek_big_trace test_seek_empty_packet
This page took 0.02299 seconds and 4 git commands to generate.