Tests: Add a CTF Writer test
[babeltrace.git] / tests / lib / Makefile.am
index 849767a77e8a4ae96e6e5899a0191aa888a676c5..e1aa471ce47b2dc5a68e3b4481f60b59676cc7c8 100644 (file)
@@ -16,10 +16,15 @@ test_seek_LDADD = $(LIBTAP) libtestcommon.a \
 
 test_bitfield_LDADD = $(LIBTAP) libtestcommon.a
 
-noinst_PROGRAMS = test_seek test_bitfield
+test_ctf_writer_LDADD = $(LIBTAP) \
+       $(top_builddir)/lib/libbabeltrace.la \
+       $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
+
+noinst_PROGRAMS = test_seek test_bitfield test_ctf_writer
 
 test_seek_SOURCES = test_seek.c
 test_bitfield_SOURCES = test_bitfield.c
+test_ctf_writer_SOURCES = test_ctf_writer.c
 
 SCRIPT_LIST = test_seek_big_trace test_seek_empty_packet
 
This page took 0.023856 seconds and 4 git commands to generate.