Rename so-info to bin-info
[babeltrace.git] / tests / lib / Makefile.am
index 50976b9b57df569c70f7e07f99b368ea9d669543..e23bcc13b6c0012c0c74dacb2d2c4206f7cd8382 100644 (file)
@@ -27,18 +27,42 @@ test_ctf_ir_ref_LDADD = $(LIBTAP) \
        $(top_builddir)/lib/libbabeltrace.la \
        $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
 
+test_bt_ctf_field_type_validation_LDADD = $(LIBTAP) \
+       $(top_builddir)/lib/libbabeltrace.la \
+       $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
+
 noinst_PROGRAMS = test_seek test_bitfield test_ctf_writer test_bt_values \
-       test_ctf_ir_ref
+       test_ctf_ir_ref test_bt_ctf_field_type_validation
 
 test_seek_SOURCES = test_seek.c
 test_bitfield_SOURCES = test_bitfield.c
 test_ctf_writer_SOURCES = test_ctf_writer.c
 test_bt_values_SOURCES = test_bt_values.c
 test_ctf_ir_ref_SOURCES = test_ctf_ir_ref.c
+test_bt_ctf_field_type_validation_SOURCES = test_bt_ctf_field_type_validation.c
 
 SCRIPT_LIST = test_seek_big_trace \
        test_seek_empty_packet \
        test_ctf_writer_complete
+EXTRA_DIST = test_seek_big_trace.in test_seek_empty_packet.in
+CLEANFILES= test_seek_big_trace test_seek_empty_packet
+
+if ENABLE_DEBUGINFO
+test_dwarf_LDFLAGS = -static
+test_dwarf_LDADD = $(LIBTAP) \
+       $(top_builddir)/lib/libbabeltrace.la \
+       $(top_builddir)/lib/libdebuginfo.la
+test_dwarf_SOURCES = test_dwarf.c
+
+test_bin_info_LDFLAGS = -static
+test_bin_info_LDADD = $(LIBTAP) \
+       $(top_builddir)/lib/libbabeltrace.la \
+       $(top_builddir)/lib/libdebuginfo.la
+test_bin_info_SOURCES = test_bin_info.c
+
+noinst_PROGRAMS += test_dwarf test_bin_info
+SCRIPT_LIST += test_dwarf_complete test_bin_info_complete
+endif
 
 dist_noinst_SCRIPTS = $(SCRIPT_LIST)
 
This page took 0.023984 seconds and 4 git commands to generate.