Handle test_ctf_writer_complete like the other tests scripts
[babeltrace.git] / tests / lib / Makefile.am
index 8c46acb533746f7cf85ce96029ff7ccd300f12c8..f2a2f5a2d04f4a6430c8b8d82b3cf27cb76e2f7b 100644 (file)
@@ -26,9 +26,26 @@ test_seek_SOURCES = test_seek.c
 test_bitfield_SOURCES = test_bitfield.c
 test_ctf_writer_SOURCES = test_ctf_writer.c
 
-SCRIPT_LIST = test_seek_big_trace \
-       test_seek_empty_packet \
-       test_ctf_writer_complete
+check_SCRIPTS = test_seek_big_trace \
+               test_seek_empty_packet \
+               test_ctf_writer_complete
+
+if ENABLE_DEBUGINFO
+test_dwarf_LDFLAGS = -static
+test_dwarf_LDADD = $(LIBTAP) \
+       $(top_builddir)/lib/libbabeltrace.la \
+       $(top_builddir)/lib/libdebuginfo.la
+test_dwarf_SOURCES = test_dwarf.c
+
+test_bin_info_LDFLAGS = -static
+test_bin_info_LDADD = $(LIBTAP) \
+       $(top_builddir)/lib/libbabeltrace.la \
+       $(top_builddir)/lib/libdebuginfo.la
+test_bin_info_SOURCES = test_bin_info.c
+
+noinst_PROGRAMS += test_dwarf test_bin_info
+SCRIPT_LIST += test_dwarf_complete test_bin_info_complete
+endif
 
 dist_noinst_SCRIPTS = $(SCRIPT_LIST)
 
This page took 0.02329 seconds and 4 git commands to generate.