tests: normalize names of files and more
[babeltrace.git] / tests / lib / Makefile.am
index 0613bebd916f62d5eaed25cce8c9c2d03af8e926..f2c70351290852f7bb0949e6fd9ab890b001219a 100644 (file)
@@ -1,19 +1,68 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
+# SPDX-License-Identifier: MIT
 
-noinst_LIBRARIES = libtestcommon.a
+SUBDIRS = utils
 
-libtestcommon_a_SOURCES = tap.c tap.h common.c common.h
+AM_CPPFLAGS += -I$(top_srcdir)/tests/utils
 
-test_seeks_LDADD = libtestcommon.a \
-       $(top_builddir)/lib/libbabeltrace.la \
-       $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
+COMMON_TEST_LDADD = \
+       $(top_builddir)/tests/utils/tap/libtap.la \
+       $(top_builddir)/tests/utils/libtestcommon.la \
+       $(top_builddir)/tests/lib/utils/liblib-utils.la \
+       $(top_builddir)/src/common/libbabeltrace2-common.la \
+       $(top_builddir)/src/logging/liblogging.la
 
-noinst_PROGRAMS = test-seeks test-bitfield
+test_bt_values_LDADD = $(COMMON_TEST_LDADD) \
+       $(top_builddir)/src/lib/libbabeltrace2.la
 
-test_seeks_SOURCES = test-seeks.c
-test_bitfield_SOURCES = test-bitfield.c
+test_fields_bin_LDADD = $(COMMON_TEST_LDADD) \
+       $(top_builddir)/src/lib/libbabeltrace2.la
 
-EXTRA_DIST = README.tap runall.sh
+test_bt_uuid_LDADD = $(COMMON_TEST_LDADD)
 
-check-am:
-       ./runall.sh
+test_trace_ir_ref_LDADD = $(COMMON_TEST_LDADD) \
+       $(top_builddir)/src/lib/libbabeltrace2.la \
+       $(top_builddir)/src/ctf-writer/libbabeltrace2-ctf-writer.la
+
+test_graph_topo_LDADD = $(COMMON_TEST_LDADD) \
+       $(top_builddir)/src/lib/libbabeltrace2.la
+
+test_simple_sink_LDADD = $(COMMON_TEST_LDADD) \
+       $(top_builddir)/src/lib/libbabeltrace2.la
+
+test_remove_destruction_listener_in_destruction_listener_LDADD = \
+       $(COMMON_TEST_LDADD) \
+       $(top_builddir)/src/lib/libbabeltrace2.la
+
+noinst_PROGRAMS = \
+       test-bt-uuid \
+       test-bt-values \
+       test-graph-topo \
+       test-fields-bin \
+       test-remove-destruction-listener-in-destruction-listener \
+       test-simple-sink \
+       test-trace-ir-ref
+
+test_bt_values_SOURCES = test-bt-values.c
+test_fields_bin_SOURCES = test-fields-bin.cpp
+test_simple_sink_SOURCES = test-simple-sink.c
+test_bt_uuid_SOURCES = test-bt-uuid.c
+test_trace_ir_ref_SOURCES = test-trace-ir-ref.c
+test_graph_topo_SOURCES = test-graph-topo.c
+test_remove_destruction_listener_in_destruction_listener_SOURCES = \
+       test-remove-destruction-listener-in-destruction-listener.c
+
+if !ENABLE_BUILT_IN_PLUGINS
+noinst_PROGRAMS += plugin
+plugin_LDADD = $(COMMON_TEST_LDADD) \
+       $(top_builddir)/src/lib/libbabeltrace2.la
+plugin_SOURCES = plugin.c
+SUBDIRS += test-plugin-plugins
+endif
+
+dist_check_SCRIPTS = test-plugin.sh test-fields.sh
+
+if HAVE_PYTHON
+if DEV_MODE
+SUBDIRS += conds
+endif
+endif
This page took 0.023876 seconds and 4 git commands to generate.