Move to kernel style SPDX license identifiers
[babeltrace.git] / tests / lib / Makefile.am
index 0613bebd916f62d5eaed25cce8c9c2d03af8e926..ff7ab1720806fe237fd0f1b6daa9156b04820cd4 100644 (file)
@@ -1,19 +1,56 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
+# SPDX-License-Identifier: MIT
 
-noinst_LIBRARIES = libtestcommon.a
+SUBDIRS =
 
-libtestcommon_a_SOURCES = tap.c tap.h common.c common.h
+AM_CPPFLAGS += -I$(top_srcdir)/tests/utils
 
-test_seeks_LDADD = libtestcommon.a \
-       $(top_builddir)/lib/libbabeltrace.la \
-       $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
+COMMON_TEST_LDADD = \
+       $(top_builddir)/tests/utils/tap/libtap.la \
+       $(top_builddir)/tests/utils/libtestcommon.la \
+       $(top_builddir)/src/common/libbabeltrace2-common.la \
+       $(top_builddir)/src/logging/libbabeltrace2-logging.la
 
-noinst_PROGRAMS = test-seeks test-bitfield
+test_bt_values_LDADD = $(COMMON_TEST_LDADD) \
+       $(top_builddir)/src/lib/libbabeltrace2.la
 
-test_seeks_SOURCES = test-seeks.c
-test_bitfield_SOURCES = test-bitfield.c
+test_bt_uuid_LDADD = $(COMMON_TEST_LDADD)
 
-EXTRA_DIST = README.tap runall.sh
+test_trace_ir_ref_LDADD = $(COMMON_TEST_LDADD) \
+       $(top_builddir)/src/lib/libbabeltrace2.la \
+       $(top_builddir)/src/ctf-writer/libbabeltrace2-ctf-writer.la
 
-check-am:
-       ./runall.sh
+test_graph_topo_LDADD = $(COMMON_TEST_LDADD) \
+       $(top_builddir)/src/lib/libbabeltrace2.la
+
+test_simple_sink_LDADD = $(COMMON_TEST_LDADD) \
+       $(top_builddir)/src/lib/libbabeltrace2.la
+
+test_remove_destruction_listener_in_destruction_listener_LDADD = \
+       $(COMMON_TEST_LDADD) \
+       $(top_builddir)/src/lib/libbabeltrace2.la
+
+noinst_PROGRAMS = \
+       test_bt_uuid \
+       test_bt_values \
+       test_graph_topo \
+       test_remove_destruction_listener_in_destruction_listener \
+       test_simple_sink \
+       test_trace_ir_ref
+
+test_bt_values_SOURCES = test_bt_values.c
+test_simple_sink_SOURCES = test_simple_sink.c
+test_bt_uuid_SOURCES = test_bt_uuid.c
+test_trace_ir_ref_SOURCES = test_trace_ir_ref.c
+test_graph_topo_SOURCES = test_graph_topo.c
+test_remove_destruction_listener_in_destruction_listener_SOURCES = \
+       test_remove_destruction_listener_in_destruction_listener.c
+
+if !ENABLE_BUILT_IN_PLUGINS
+noinst_PROGRAMS += plugin
+plugin_LDADD = $(COMMON_TEST_LDADD) \
+       $(top_builddir)/src/lib/libbabeltrace2.la
+plugin_SOURCES = plugin.c
+SUBDIRS += test-plugin-plugins
+endif
+
+dist_check_SCRIPTS = test_plugin
This page took 0.023751 seconds and 4 git commands to generate.