Move to kernel style SPDX license identifiers
[babeltrace.git] / tests / lib / Makefile.am
index 593999c8aeb2967316c612f5fdc6412adcf51469..ff7ab1720806fe237fd0f1b6daa9156b04820cd4 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: MIT
+
 SUBDIRS =
 
 AM_CPPFLAGS += -I$(top_srcdir)/tests/utils
@@ -23,18 +25,25 @@ test_graph_topo_LDADD = $(COMMON_TEST_LDADD) \
 test_simple_sink_LDADD = $(COMMON_TEST_LDADD) \
        $(top_builddir)/src/lib/libbabeltrace2.la
 
+test_remove_destruction_listener_in_destruction_listener_LDADD = \
+       $(COMMON_TEST_LDADD) \
+       $(top_builddir)/src/lib/libbabeltrace2.la
+
 noinst_PROGRAMS = \
-       test_bt_values \
        test_bt_uuid \
-       test_trace_ir_ref \
+       test_bt_values \
        test_graph_topo \
-       test_simple_sink
+       test_remove_destruction_listener_in_destruction_listener \
+       test_simple_sink \
+       test_trace_ir_ref
 
 test_bt_values_SOURCES = test_bt_values.c
 test_simple_sink_SOURCES = test_simple_sink.c
 test_bt_uuid_SOURCES = test_bt_uuid.c
 test_trace_ir_ref_SOURCES = test_trace_ir_ref.c
 test_graph_topo_SOURCES = test_graph_topo.c
+test_remove_destruction_listener_in_destruction_listener_SOURCES = \
+       test_remove_destruction_listener_in_destruction_listener.c
 
 if !ENABLE_BUILT_IN_PLUGINS
 noinst_PROGRAMS += plugin
This page took 0.023672 seconds and 4 git commands to generate.