Move to kernel style SPDX license identifiers
[babeltrace.git] / tests / lib / Makefile.am
index d02d14960d615d3127e4841e0047476efd6b69e1..ff7ab1720806fe237fd0f1b6daa9156b04820cd4 100644 (file)
@@ -1,74 +1,56 @@
-SUBDIRS = test-plugin-plugins writer .
+# SPDX-License-Identifier: MIT
 
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include -I$(top_srcdir)/tests/utils
+SUBDIRS =
 
-LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
+AM_CPPFLAGS += -I$(top_srcdir)/tests/utils
 
-libtestcommon_la_SOURCES = common.c common.h
-noinst_LTLIBRARIES = libtestcommon.la
+COMMON_TEST_LDADD = \
+       $(top_builddir)/tests/utils/tap/libtap.la \
+       $(top_builddir)/tests/utils/libtestcommon.la \
+       $(top_builddir)/src/common/libbabeltrace2-common.la \
+       $(top_builddir)/src/logging/libbabeltrace2-logging.la
 
-# -Wl,--no-as-needed is needed for recent gold linker who seems to think
-# it knows better and considers libraries with constructors having
-# side-effects as dead code.
-test_seek_LDFLAGS = $(LD_NO_AS_NEEDED)
-COMMON_TEST_LDADD = $(LIBTAP) $(builddir)/libtestcommon.la \
-       $(top_builddir)/lib/libbabeltrace.la \
-       $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
+test_bt_values_LDADD = $(COMMON_TEST_LDADD) \
+       $(top_builddir)/src/lib/libbabeltrace2.la
 
-test_seek_LDADD = $(COMMON_TEST_LDADD)
+test_bt_uuid_LDADD = $(COMMON_TEST_LDADD)
 
-test_bitfield_LDADD = $(LIBTAP) $(builddir)/libtestcommon.la
+test_trace_ir_ref_LDADD = $(COMMON_TEST_LDADD) \
+       $(top_builddir)/src/lib/libbabeltrace2.la \
+       $(top_builddir)/src/ctf-writer/libbabeltrace2-ctf-writer.la
 
-test_ctf_writer_LDADD = $(COMMON_TEST_LDADD)
+test_graph_topo_LDADD = $(COMMON_TEST_LDADD) \
+       $(top_builddir)/src/lib/libbabeltrace2.la
 
-test_bt_values_LDADD = $(LIBTAP) \
-       $(top_builddir)/lib/libbabeltrace.la
+test_simple_sink_LDADD = $(COMMON_TEST_LDADD) \
+       $(top_builddir)/src/lib/libbabeltrace2.la
 
-test_ctf_ir_ref_LDADD = $(COMMON_TEST_LDADD)
+test_remove_destruction_listener_in_destruction_listener_LDADD = \
+       $(COMMON_TEST_LDADD) \
+       $(top_builddir)/src/lib/libbabeltrace2.la
 
-test_bt_ctf_field_type_validation_LDADD = $(COMMON_TEST_LDADD)
+noinst_PROGRAMS = \
+       test_bt_uuid \
+       test_bt_values \
+       test_graph_topo \
+       test_remove_destruction_listener_in_destruction_listener \
+       test_simple_sink \
+       test_trace_ir_ref
 
-test_ir_visit_LDADD = $(COMMON_TEST_LDADD)
-
-test_trace_listener_LDADD = $(COMMON_TEST_LDADD)
-
-test_bt_notification_heap_LDADD = $(COMMON_TEST_LDADD)
-
-test_plugin_LDADD = $(COMMON_TEST_LDADD)
-
-noinst_PROGRAMS = test_seek test_bitfield test_ctf_writer test_bt_values \
-       test_ctf_ir_ref test_bt_ctf_field_type_validation test_ir_visit \
-       test_trace_listener test_bt_notification_heap test_plugin
-
-test_seek_SOURCES = test_seek.c
-test_bitfield_SOURCES = test_bitfield.c
-test_ctf_writer_SOURCES = test_ctf_writer.c
 test_bt_values_SOURCES = test_bt_values.c
-test_ctf_ir_ref_SOURCES = test_ctf_ir_ref.c
-test_bt_ctf_field_type_validation_SOURCES = test_bt_ctf_field_type_validation.c
-test_ir_visit_SOURCES = test_ir_visit.c
-test_trace_listener_SOURCES = test_trace_listener.c
-test_bt_notification_heap_SOURCES = test_bt_notification_heap.c
-test_plugin_SOURCES = test_plugin.c
-
-check_SCRIPTS = test_seek_big_trace \
-               test_seek_empty_packet \
-               test_ctf_writer_complete \
-               test_plugin_complete
-
-if ENABLE_DEBUG_INFO
-test_dwarf_LDFLAGS = -static
-test_dwarf_LDADD = $(LIBTAP) \
-       $(top_builddir)/lib/libbabeltrace.la \
-       $(top_builddir)/lib/libdebug-info.la
-test_dwarf_SOURCES = test_dwarf.c
-
-test_bin_info_LDFLAGS = -static
-test_bin_info_LDADD = $(LIBTAP) \
-       $(top_builddir)/lib/libbabeltrace.la \
-       $(top_builddir)/lib/libdebug-info.la
-test_bin_info_SOURCES = test_bin_info.c
-
-noinst_PROGRAMS += test_dwarf test_bin_info
-check_SCRIPTS += test_dwarf_complete test_bin_info_complete
+test_simple_sink_SOURCES = test_simple_sink.c
+test_bt_uuid_SOURCES = test_bt_uuid.c
+test_trace_ir_ref_SOURCES = test_trace_ir_ref.c
+test_graph_topo_SOURCES = test_graph_topo.c
+test_remove_destruction_listener_in_destruction_listener_SOURCES = \
+       test_remove_destruction_listener_in_destruction_listener.c
+
+if !ENABLE_BUILT_IN_PLUGINS
+noinst_PROGRAMS += plugin
+plugin_LDADD = $(COMMON_TEST_LDADD) \
+       $(top_builddir)/src/lib/libbabeltrace2.la
+plugin_SOURCES = plugin.c
+SUBDIRS += test-plugin-plugins
 endif
+
+dist_check_SCRIPTS = test_plugin
This page took 0.025522 seconds and 4 git commands to generate.