Move to kernel style SPDX license identifiers
[babeltrace.git] / tests / lib / test-plugin-plugins / Makefile.am
index dc4b5a2486fef3b80cfa632ca3f4f1bc9e86b686..c1826939cbbea699f5aeca922f30a3aad4dd50ba 100644 (file)
@@ -1,34 +1,23 @@
-AM_CFLAGS = $(PACKAGE_CFLAGS) -I$(top_srcdir)/include
-COMMONLIBADD = \
-       $(top_builddir)/lib/libbabeltrace.la \
-       $(top_builddir)/formats/ctf/libbabeltrace-ctf.la
+# SPDX-License-Identifier: MIT
 
-# It seems like Automake won't make Libtool create a shared object
-# (which we need here since we're building plugins) with a noinst_
-# destination (no install). Indeed we don't want to install those test
-# plugins. Libtool creates a shared object when it gets an -rpath
-# argument. In this case, Libtool does not seem to care much about
-# the actual argument, so we use / (because Libtool needs an absolute
-# path), which in the end is not even part of the linked object's
-# rpath.
-#
-# -module makes it possible to not use the `lib` prefix and it makes
-# sure that all symbols are dynamically exported.
-COMMONLDFLAGS = -rpath / -avoid-version -module
-
-noinst_LTLIBRARIES = plugin-minimal.la plugin-sfs.la plugin-invalid.la
+noinst_LTLIBRARIES = plugin-minimal.la plugin-sfs.la
 
 # the minimal plugin
 plugin_minimal_la_SOURCES = minimal.c
-plugin_minimal_la_LDFLAGS = $(COMMONLDFLAGS)
-plugin_minimal_la_LIBADD = $(COMMONLIBADD)
+plugin_minimal_la_LDFLAGS = \
+       $(LT_NO_UNDEFINED) \
+       -rpath / -avoid-version -module
+plugin_minimal_la_LIBADD = \
+       $(top_builddir)/src/lib/libbabeltrace2.la \
+       $(top_builddir)/src/common/libbabeltrace2-common.la \
+       $(top_builddir)/src/logging/libbabeltrace2-logging.la
 
 # source/filter/sink plugin
 plugin_sfs_la_SOURCES = sfs.c
-plugin_sfs_la_LDFLAGS = $(COMMONLDFLAGS)
-plugin_sfs_la_LIBADD = $(COMMONLIBADD)
-
-# invalid plugin
-plugin_invalid_la_SOURCES = invalid.c
-plugin_invalid_la_LDFLAGS = $(COMMONLDFLAGS)
-plugin_invalid_la_LIBADD = $(COMMONLIBADD)
+plugin_sfs_la_LDFLAGS = \
+       $(LT_NO_UNDEFINED) \
+       -rpath / -avoid-version -module
+plugin_sfs_la_LIBADD = \
+       $(top_builddir)/src/lib/libbabeltrace2.la \
+       $(top_builddir)/src/common/libbabeltrace2-common.la \
+       $(top_builddir)/src/logging/libbabeltrace2-logging.la
This page took 0.033449 seconds and 4 git commands to generate.