tests: build system spring cleanup
[babeltrace.git] / tests / plugins / Makefile.am
index ffea78bd90f4c1a3d30a29c9f1c4b9e4fe8bcb19..8744e8ae32fe771aed65d89920a77a7e46244c25 100644 (file)
@@ -1,27 +1,23 @@
 AM_CPPFLAGS += -I$(top_srcdir)/tests/utils -I$(top_srcdir)/plugins
 
 LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
-COMMON_TEST_LDADD = $(LIBTAP) \
-       $(top_builddir)/lib/libbabeltrace.la \
-       $(top_builddir)/common/libbabeltrace-common.la \
-       $(top_builddir)/logging/libbabeltrace-logging.la \
-       $(top_builddir)/compat/libcompat.la
-
-noinst_PROGRAMS = test-utils-muxer
-
-test_utils_muxer_SOURCES = test-utils-muxer.c
-test_utils_muxer_LDADD = $(COMMON_TEST_LDADD)
 
-check_SCRIPTS = test-utils-muxer-complete
+dist_check_SCRIPTS = \
+       test_lttng_utils_debug_info.py\
+       ctf/test_query_trace_info.py
 
-LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) $(top_srcdir)/config/tap-driver.sh
-LOG_DRIVER_FLAGS='--merge'
+noinst_PROGRAMS =
 
-TESTS = test-utils-muxer-complete
+if !ENABLE_BUILT_IN_PLUGINS
+# plugin tests here
+endif # !ENABLE_BUILT_IN_PLUGINS
 
 if ENABLE_DEBUG_INFO
+noinst_PROGRAMS += test_dwarf test_bin_info
+
 test_dwarf_LDADD = \
-       $(top_builddir)/plugins/lttng-utils/libdebug-info.la \
+       $(top_builddir)/plugins/lttng-utils/debug-info/libdebug-info.la \
+       $(top_builddir)/fd-cache/libbabeltrace-fd-cache.la \
        $(top_builddir)/logging/libbabeltrace-logging.la \
        $(top_builddir)/common/libbabeltrace-common.la \
        $(ELFUTILS_LIBS) \
@@ -29,15 +25,11 @@ test_dwarf_LDADD = \
 test_dwarf_SOURCES = test_dwarf.c
 
 test_bin_info_LDADD = \
-       $(top_builddir)/plugins/lttng-utils/libdebug-info.la \
+       $(top_builddir)/plugins/lttng-utils/debug-info/libdebug-info.la \
+       $(top_builddir)/fd-cache/libbabeltrace-fd-cache.la \
        $(top_builddir)/logging/libbabeltrace-logging.la \
        $(top_builddir)/common/libbabeltrace-common.la \
        $(ELFUTILS_LIBS) \
        $(LIBTAP)
 test_bin_info_SOURCES = test_bin_info.c
-
-noinst_PROGRAMS += test_dwarf test_bin_info
-check_SCRIPTS += test_dwarf_complete test_bin_info_complete
-TESTS += test_dwarf_complete \
-       test_bin_info_complete
-endif
+endif # ENABLE_DEBUG_INFO
This page took 0.023786 seconds and 4 git commands to generate.