Re-enable the bin-info and dward tests
[babeltrace.git] / tests / plugins / Makefile.am
index 867ddd9659abbfc38756e5256bddfe79e21a49c8..e34e66a6e1ac3693c455314d75f844191b3ced43 100644 (file)
@@ -1,4 +1,4 @@
-AM_CPPFLAGS += -I$(top_srcdir)/tests/utils
+AM_CPPFLAGS += -I$(top_srcdir)/tests/utils -I$(top_srcdir)/plugins
 
 LIBTAP=$(top_builddir)/tests/utils/tap/libtap.la
 COMMON_TEST_LDADD = $(LIBTAP) \
@@ -18,3 +18,20 @@ LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) $(top_srcdir)/config/tap-driver.sh
 LOG_DRIVER_FLAGS='--merge'
 
 TESTS = test-utils-muxer-complete
+
+if ENABLE_DEBUG_INFO
+test_dwarf_LDFLAGS = -static
+test_dwarf_LDADD = $(LIBTAP) \
+       $(top_builddir)/plugins/lttng-utils/babeltrace-plugin-lttng-utils.la
+test_dwarf_SOURCES = test_dwarf.c
+
+test_bin_info_LDFLAGS = -static
+test_bin_info_LDADD = $(LIBTAP) \
+       $(top_builddir)/plugins/lttng-utils/babeltrace-plugin-lttng-utils.la
+test_bin_info_SOURCES = test_bin_info.c
+
+noinst_PROGRAMS += test_dwarf test_bin_info
+check_SCRIPTS += test_dwarf_complete test_bin_info_complete
+TESTS += test_dwarf_complete \
+       test_bin_info_complete
+endif
This page took 0.023576 seconds and 4 git commands to generate.