Make API CTF-agnostic
[babeltrace.git] / tests / plugins / Makefile.am
index ffea78bd90f4c1a3d30a29c9f1c4b9e4fe8bcb19..e68d66717021dddd723e9664662accc5778f5f3c 100644 (file)
@@ -7,17 +7,12 @@ COMMON_TEST_LDADD = $(LIBTAP) \
        $(top_builddir)/logging/libbabeltrace-logging.la \
        $(top_builddir)/compat/libcompat.la
 
-noinst_PROGRAMS = test-utils-muxer
+check_SCRIPTS =
+noinst_PROGRAMS =
 
-test_utils_muxer_SOURCES = test-utils-muxer.c
-test_utils_muxer_LDADD = $(COMMON_TEST_LDADD)
-
-check_SCRIPTS = test-utils-muxer-complete
-
-LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) $(top_srcdir)/config/tap-driver.sh
-LOG_DRIVER_FLAGS='--merge'
-
-TESTS = test-utils-muxer-complete
+if !ENABLE_BUILT_IN_PLUGINS
+# plugin tests here
+endif # !ENABLE_BUILT_IN_PLUGINS
 
 if ENABLE_DEBUG_INFO
 test_dwarf_LDADD = \
@@ -38,6 +33,12 @@ test_bin_info_SOURCES = test_bin_info.c
 
 noinst_PROGRAMS += test_dwarf test_bin_info
 check_SCRIPTS += test_dwarf_complete test_bin_info_complete
-TESTS += test_dwarf_complete \
-       test_bin_info_complete
-endif
+
+if !ENABLE_BUILT_IN_PLUGINS
+if ENABLE_PYTHON_BINDINGS
+check_SCRIPTS += test_lttng_utils_debug_info
+endif # !ENABLE_BUILT_IN_PLUGINS
+endif # ENABLE_PYTHON_BINDINGS
+endif # ENABLE_DEBUG_INFO
+
+EXTRA_DIST = test_lttng_utils_debug_info.py
This page took 0.024928 seconds and 4 git commands to generate.