configure.ac: add check for popt library
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 3 Nov 2011 12:00:19 +0000 (08:00 -0400)
committerMathieu Desnoyers <mathieu.desnoyers@efficios.com>
Thu, 3 Nov 2011 12:00:19 +0000 (08:00 -0400)
The popt library is used by babeltrace but isn't checked in
configure.ac, so the compilation fails due to popt.h being missing if
popt is not already installed on the system.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
configure.ac

index f8a80e5fbe0b965be49692dc375fe655ef1bf742..4446f29065c65efc6d7f0544b0e92c7807e9b578 100644 (file)
@@ -40,6 +40,10 @@ AC_CHECK_LIB([uuid], [uuid_generate], [],
        [AC_MSG_ERROR([Cannot find libuuid. Use [LDFLAGS]=-Ldir to specify its location.])]
 )
 
+AC_CHECK_LIB([popt], [poptGetContext], [],
+        [AC_MSG_ERROR([Cannot find popt.])]
+)
+
 pkg_modules="gmodule-2.0 >= 2.0.0"
 PKG_CHECK_MODULES(GMODULE, [$pkg_modules])
 AC_SUBST(PACKAGE_LIBS)
This page took 0.033991 seconds and 4 git commands to generate.