Fix: libbabeltrace lib build dependencies
authorMathieu Desnoyers <mathieu.desnoyers@efficios.com>
Mon, 9 Dec 2013 12:28:51 +0000 (07:28 -0500)
committerMathieu Desnoyers <mathieu.desnoyers@efficios.com>
Mon, 9 Dec 2013 12:28:51 +0000 (07:28 -0500)
The "no-as-needed" is only needed for plugins, not for libraries we
depend upon, so it is not really needed here. Using LIBADD instead
ensures that libbabeltrace gets rebuilt whenever the content of
libbabeltrace_types (statically linked) is modified.

Signed-off-by: Mathieu Desnoyers <mathieu.desnoyers@efficios.com>
lib/Makefile.am

index fa470c09cf5f9b8f44706633600482214485c220..4b78b4778f6be7f709e48b824fcefa4a7b64581c 100644 (file)
@@ -11,8 +11,7 @@ libbabeltrace_la_SOURCES = babeltrace.c \
                           trace-collection.c \
                           registry.c
 
-libbabeltrace_la_LDFLAGS = \
-       -Wl,--no-as-needed \
+libbabeltrace_la_LIBADD = \
        prio_heap/libprio_heap.la \
        $(top_builddir)/types/libbabeltrace_types.la \
        $(top_builddir)/compat/libcompat.la
This page took 0.023627 seconds and 4 git commands to generate.