Set the minimal version of elfutils to 0.154
authorJérémie Galarneau <jeremie.galarneau@efficios.com>
Thu, 28 Apr 2016 16:09:58 +0000 (12:09 -0400)
committerJérémie Galarneau <jeremie.galarneau@efficios.com>
Tue, 3 May 2016 19:42:42 +0000 (15:42 -0400)
elfutils 0.154 is required since it is the first release to
include commit 5479725 (dwarf_highpc: Handle DW_AT_high_pc being
a constant offset from DW_AT_low_pc).

This is fix is required to read DwARF information produced by
"modern" (post-2012) GCCs which make use of this DWARF4
capability when generating position independant code. The binaries
provided as part of the test suite make use of this feature. Hence,
tests will fail with older elfutils versions.

Signed-off-by: Jérémie Galarneau <jeremie.galarneau@efficios.com>
README

diff --git a/README b/README
index 35033e1789bd10699c56548597ceeb3f5148a67e..c44b5e9892a0bd1f71186c6948e44f120378ad20 100644 (file)
--- a/README
+++ b/README
@@ -49,7 +49,7 @@ To compile Babeltrace, you will need:
        libpopt >= 1.13 development libraries
          (Debian : libpopt-dev)
          (Fedora : popt)
-       elfutils development libraries (optional)
+       elfutils >= 0.154 development libraries (optional)
          (Debian : libelf-dev, libdw-dev)
          (Fedora : elfutils-devel, elfutils-libelf-devel)
        python headers (optional)
This page took 0.032804 seconds and 4 git commands to generate.