SoW-2020-0002: Trace Hit Counters: Implement key-addressed counters in shared memory...
[deliverable/lttng-ust.git] / liblttng-ust / Makefile.am
index 3f4c023db24acaaf646259982dfcacd0491ed92e..2f1fb2a8d99ec1fa5ca12977e2ef010638b8d0c0 100644 (file)
@@ -23,9 +23,15 @@ liblttng_ust_tracepoint_la_LDFLAGS = -no-undefined -version-info $(LTTNG_UST_LIB
 liblttng_ust_tracepoint_la_CFLAGS = -DUST_COMPONENT="liblttng_ust_tracepoint" $(AM_CFLAGS)
 
 liblttng_ust_runtime_la_SOURCES = \
+       bytecode.h \
        lttng-ust-comm.c \
        lttng-ust-abi.c \
        lttng-probes.c \
+       lttng-bytecode.c \
+       lttng-bytecode.h \
+       lttng-bytecode-validator.c \
+       lttng-bytecode-specialize.c \
+       lttng-bytecode-interpreter.c \
        lttng-context-provider.c \
        lttng-context-vtid.c \
        lttng-context-vpid.c \
@@ -49,12 +55,6 @@ liblttng_ust_runtime_la_SOURCES = \
        lttng-context-vsgid.c \
        lttng-context.c \
        lttng-events.c \
-       lttng-filter.c \
-       lttng-filter.h \
-       lttng-filter-validator.c \
-       lttng-filter-specialize.c \
-       lttng-filter-interpreter.c \
-       filter-bytecode.h \
        lttng-hash-helper.h \
        lttng-ust-elf.c \
        lttng-ust-statedump.c \
@@ -62,7 +62,10 @@ liblttng_ust_runtime_la_SOURCES = \
        lttng-ust-statedump-provider.h \
        ust_lib.c \
        ust_lib.h \
+       context-internal.h \
+       context-provider-internal.h \
        tracepoint-internal.h \
+       ust-events-internal.h \
        clock.h \
        compat.h \
        wait.h \
@@ -76,6 +79,7 @@ liblttng_ust_runtime_la_SOURCES = \
        getenv.h \
        string-utils.c \
        string-utils.h \
+       trigger-notification.c \
        ns.h \
        creds.h
 
@@ -100,6 +104,8 @@ liblttng_ust_support_la_SOURCES = \
        lttng-ring-buffer-client-overwrite-rt.c \
        lttng-ring-buffer-metadata-client.h \
        lttng-ring-buffer-metadata-client.c \
+       lttng-counter-client-percpu-32-modular.c \
+       lttng-counter-client-percpu-64-modular.c \
        lttng-clock.c lttng-getcpu.c
 
 liblttng_ust_la_SOURCES =
@@ -107,7 +113,8 @@ liblttng_ust_la_SOURCES =
 liblttng_ust_la_LDFLAGS = -no-undefined -version-info $(LTTNG_UST_LIBRARY_VERSION)
 
 liblttng_ust_support_la_LIBADD = \
-       $(top_builddir)/libringbuffer/libringbuffer.la
+       $(top_builddir)/libringbuffer/libringbuffer.la \
+       $(top_builddir)/libcounter/libcounter.la
 
 liblttng_ust_la_LIBADD = \
        -lpthread \
@@ -117,6 +124,7 @@ liblttng_ust_la_LIBADD = \
        $(top_builddir)/liblttng-ust-comm/liblttng-ust-comm.la \
        liblttng-ust-tracepoint.la \
        liblttng-ust-runtime.la liblttng-ust-support.la \
+       $(top_builddir)/libmsgpack/libmsgpack.la \
        $(DL_LIBS)
 
 liblttng_ust_la_CFLAGS = -DUST_COMPONENT="liblttng_ust" $(AM_CFLAGS)
This page took 0.025855 seconds and 5 git commands to generate.