port: tests: Add a simple unit test for shm operations
[deliverable/lttng-ust.git] / tests / Makefile.am
index eca4e20abd42e222c02a5d3f75c34fb622896b71..6792b0b9b027fea97d551fe4053f6cffba2858a4 100644 (file)
@@ -1,3 +1,24 @@
-SUBDIRS = hello hello2 basic basic_long fork simple_include snprintf test-nevents
+SUBDIRS = utils unit compile benchmark
 
-noinst_SCRIPTS = test_loop runtests trace_matches
+LOG_DRIVER_FLAGS='--merge'
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+       $(srcdir)/utils/tap-driver.sh
+
+TESTS = \
+       unit/libringbuffer/test_shm \
+       unit/gcc-weak-hidden/test_gcc_weak_hidden \
+       unit/pthread_name/test_pthread_name \
+       unit/snprintf/test_snprintf \
+       unit/ust-elf/test_ust_elf
+
+EXTRA_DIST = README
+
+check-loop:
+       while [ 0 ]; do \
+               $(MAKE) $(AM_MAKEFLAGS) check; \
+               if [ "$$?" != "0" ]; then \
+                       break; \
+               fi \
+       done
+
+.PHONY: check-loop
This page took 0.024964 seconds and 5 git commands to generate.