Fix: Don't override user variables within the build system
[deliverable/lttng-ust.git] / tests / hello / Makefile.am
index 0c4c3113bcdcaa6d8a7154e44f550b9e8e5fb40a..cb4d46266646fd57fd79a2806c4bc755e1593ffa 100644 (file)
@@ -1,9 +1,9 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -Wsystem-headers
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include -Wsystem-headers
 
 noinst_PROGRAMS = hello
 hello_SOURCES = hello.c tp.c ust_tests_hello.h
 hello_LDADD = $(top_builddir)/liblttng-ust/liblttng-ust.la
-hello_CFLAGS = -Werror=old-style-definition
+hello_CFLAGS = -Werror=old-style-definition $(AM_CFLAGS)
 
 if LTTNG_UST_BUILD_WITH_LIBDL
 hello_LDADD += -ldl
@@ -11,6 +11,3 @@ endif
 if LTTNG_UST_BUILD_WITH_LIBC_DL
 hello_LDADD += -lc
 endif
-
-noinst_SCRIPTS = run
-EXTRA_DIST = run
This page took 0.025021 seconds and 5 git commands to generate.