Fix: make check in out of tree build
[deliverable/lttng-ust.git] / tests / ust-elf / Makefile.am
index 3cb544235c0551b1eb982a6dc89df2191ec30652..368e427ea39e4f034b1ae109a0faf8f93023370b 100644 (file)
@@ -5,20 +5,10 @@ prog_SOURCES = prog.c
 prog_LDADD = $(top_builddir)/liblttng-ust/liblttng-ust.la \
        $(top_builddir)/tests/utils/libtap.a
 
-SCRIPT_LIST = test_ust_elf
+noinst_SCRIPTS = test_ust_elf
+CLEANFILES = $(noinst_SCRIPTS)
+EXTRA_DIST = test_ust_elf.in $(srcdir)/data/**
 
-dist_noinst_SCRIPTS = $(SCRIPT_LIST)
-
-all-local:
-       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
-               for script in $(SCRIPT_LIST); do \
-                       cp -f $(srcdir)/$$script $(builddir); \
-               done; \
-       fi
-
-clean-local:
-       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
-               for script in $(SCRIPT_LIST); do \
-                       rm -f $(builddir)/$$script; \
-               done; \
-       fi
+$(noinst_SCRIPTS): %: %.in
+       sed "s#@TOPSRCDIR@#$(top_srcdir)#g" < $< > $@
+       chmod +x $@
This page took 0.025622 seconds and 5 git commands to generate.