Add demo unit test
[libside.git] / tests / Makefile.am
index 5db6c08769f09d04a7851165f5222d131970f78c..e83a23900f7aef68f624322d3228a90b0332285d 100644 (file)
@@ -14,7 +14,8 @@ TAP_LOG_DRIVER = env AM_TAP_AWK='$(AWK)' \
 
 noinst_PROGRAMS = \
        regression/side-rcu-test \
-       unit/test
+       unit/test \
+       unit/demo
 
 regression_side_rcu_test_SOURCES = regression/side-rcu-test.c
 regression_side_rcu_test_LDADD = \
@@ -29,5 +30,11 @@ unit_test_LDADD = \
        $(top_builddir)/tests/utils/libtap.la \
        $(RSEQ_LIBS)
 
+unit_demo_SOURCES = unit/demo.c
+unit_demo_LDADD = \
+       $(top_builddir)/src/libside.la \
+       $(top_builddir)/tests/utils/libtap.la \
+       $(RSEQ_LIBS)
+
 # Currently no tap tests to run
 TESTS =
This page took 0.022674 seconds and 4 git commands to generate.