Implement statedump unit test
[libside.git] / tests / Makefile.am
index e83a23900f7aef68f624322d3228a90b0332285d..e92b7f4217147eb415311f552a698981e42e1844 100644 (file)
@@ -15,7 +15,8 @@ TAP_LOG_DRIVER = env AM_TAP_AWK='$(AWK)' \
 noinst_PROGRAMS = \
        regression/side-rcu-test \
        unit/test \
-       unit/demo
+       unit/demo \
+       unit/statedump
 
 regression_side_rcu_test_SOURCES = regression/side-rcu-test.c
 regression_side_rcu_test_LDADD = \
@@ -36,5 +37,11 @@ unit_demo_LDADD = \
        $(top_builddir)/tests/utils/libtap.la \
        $(RSEQ_LIBS)
 
+unit_statedump_SOURCES = unit/statedump.c
+unit_statedump_LDADD = \
+       $(top_builddir)/src/libside.la \
+       $(top_builddir)/tests/utils/libtap.la \
+       $(RSEQ_LIBS)
+
 # Currently no tap tests to run
 TESTS =
This page took 0.023684 seconds and 4 git commands to generate.