doc/man: use propagated default values in man pages
[lttng-tools.git] / doc / man / Makefile.am
index d8882028a594bcc15b2f650b0184e50401774ca0..075ab8ba0f0f36bf8987c0787e0faa152fdc8f3b 100644 (file)
@@ -1,5 +1,4 @@
-# Man pages are only built if the --enable-man-pages option was
-# passed to the configure script.
+# Man pages are only built if they are enabled at configure time.
 #
 # They should always be built before creating a distribution tarball.
 
@@ -77,8 +76,7 @@ if MAN_PAGES_OPT
 # at this point, we know the user asked to build the man pages
 if HAVE_ASCIIDOC_XMLTO
 # tools
-ADOC = $(ASCIIDOC) -f $(ASCIIDOC_CONF) -d manpage \
-       -a lttng_version="$(PACKAGE_VERSION)"
+ADOC = $(ASCIIDOC) -f $(ASCIIDOC_CONF) -d manpage
 ADOC_DOCBOOK = $(ADOC) -b docbook
 XTO = $(XMLTO) -m $(firstword $(XSL_SRC_FILES)) man
 
@@ -135,5 +133,11 @@ dist_man3_MANS += $(MAN3)
 dist_man8_MANS += $(MAN8)
 endif # MAN_PAGES_OPT
 
+if !MAN_PAGES_OPT
+dist-hook:
+       @echo "Error: Please enable the man pages before creating a distribution tarball."
+       @false
+endif # !MAN_PAGES_OPT
+
 # always distribute the source files
-EXTRA_DIST = $(MAN_TXT) $(COMMON_TXT) $(XSL_SRC_FILES) $(ASCIIDOC_CONF)
+EXTRA_DIST = $(MAN_TXT) $(COMMON_TXT) $(XSL_SRC_FILES) $(ASCIIDOC_CONF).in
This page took 0.025094 seconds and 5 git commands to generate.