doc/man: put AsciiDoc attributes in their own file
[lttng-tools.git] / doc / man / Makefile.am
index 3cd3effc668723ca75e38ca9c0e75fc7387bfe94..860c8be209a2fff01034c4a90578fd1c6bc405e3 100644 (file)
@@ -52,7 +52,8 @@ COMMON_TXT = \
        $(srcdir)/common-cmd-help-options.txt
 
 # config
-ASCIIDOC_CONF = $(srcdir)/asciidoc.conf
+ASCIIDOC_CONF = $(builddir)/asciidoc.conf
+ASCIIDOC_ATTRS_CONF = $(builddir)/asciidoc-attrs.conf
 XSL_FILES = \
        manpage.xsl \
        manpage-callouts.xsl \
@@ -76,10 +77,7 @@ if MAN_PAGES_OPT
 # at this point, we know the user asked to build the man pages
 if HAVE_ASCIIDOC_XMLTO
 # tools
-ADOC = $(ASCIIDOC) -f $(ASCIIDOC_CONF) -d manpage \
-       -a lttng_version="$(PACKAGE_VERSION)" \
-       -a system_sessions_dir="$(sysconfdir)/lttng/sessions" \
-       -a system_lttng_conf="$(sysconfdir)/lttng/lttng.conf"
+ADOC = $(ASCIIDOC) -f $(ASCIIDOC_CONF) -f $(ASCIIDOC_ATTRS_CONF) -d manpage
 ADOC_DOCBOOK = $(ADOC) -b docbook
 XTO = $(XMLTO) -m $(firstword $(XSL_SRC_FILES)) man
 
@@ -143,4 +141,5 @@ dist-hook:
 endif # !MAN_PAGES_OPT
 
 # always distribute the source files
-EXTRA_DIST = $(MAN_TXT) $(COMMON_TXT) $(XSL_SRC_FILES) $(ASCIIDOC_CONF)
+EXTRA_DIST = $(MAN_TXT) $(COMMON_TXT) $(XSL_SRC_FILES) \
+       $(ASCIIDOC_CONF) $(ASCIIDOC_ATTRS_CONF).in
This page took 0.026474 seconds and 5 git commands to generate.