Fix: add dependency to libcommon for python binding
[lttng-tools.git] / extras / bindings / swig / python / Makefile.am
index 6e7baa69d86fc8eb3ef6bc576859d62ef0607a9a..ec359305493e7bdda4123bc3321d0a3e72b0c173 100644 (file)
@@ -1,7 +1,7 @@
 lttng.i: lttng.i.in
        sed "s/LTTNG_VERSION_STR/LTTng $(PACKAGE_VERSION)/g" <lttng.i.in >lttng.i
 
 lttng.i: lttng.i.in
        sed "s/LTTNG_VERSION_STR/LTTng $(PACKAGE_VERSION)/g" <lttng.i.in >lttng.i
 
-AM_CFLAGS = -I$(PYTHON_INCLUDE) -I$(top_srcdir)/lib/lttng-ctl -I../common \
+AM_CFLAGS = $(PYTHON_INCLUDE) -I$(top_srcdir)/lib/lttng-ctl -I../common \
               $(BUDDY_CFLAGS)
 
 EXTRA_DIST = lttng.i.in
               $(BUDDY_CFLAGS)
 
 EXTRA_DIST = lttng.i.in
@@ -13,7 +13,8 @@ MAINTAINERCLEANFILES = lttng_wrap.c lttng.py
 nodist__lttng_la_SOURCES = lttng_wrap.c
 _lttng_la_LDFLAGS = -module
 _lttng_la_LIBADD =     $(top_srcdir)/src/lib/lttng-ctl/liblttng-ctl.la                 \
 nodist__lttng_la_SOURCES = lttng_wrap.c
 _lttng_la_LDFLAGS = -module
 _lttng_la_LIBADD =     $(top_srcdir)/src/lib/lttng-ctl/liblttng-ctl.la                 \
-                       $(top_srcdir)/src/common/sessiond-comm/libsessiond-comm.la
+                       $(top_srcdir)/src/common/sessiond-comm/libsessiond-comm.la              \
+                       $(top_srcdir)/src/common/libcommon.la
 
 lttng_wrap.c: lttng.i
        $(SWIG) -python -I. -I$(top_srcdir)/src/common/sessiond-comm lttng.i
 
 lttng_wrap.c: lttng.i
        $(SWIG) -python -I. -I$(top_srcdir)/src/common/sessiond-comm lttng.i
This page took 0.024592 seconds and 5 git commands to generate.