SoW-2019-0002: Dynamic Snapshot
[lttng-tools.git] / include / Makefile.am
index ccd0d87d62dc6ff3ecd9bfe0393cf84baaf44167..4fdd78c7d0681080c4ca0e8e2b3ee5f1f8a1f25e 100644 (file)
@@ -121,11 +121,17 @@ lttnginclude_HEADERS = \
 
 lttngactioninclude_HEADERS= \
        lttng/action/action.h \
-       lttng/action/notify.h
+       lttng/action/group.h \
+       lttng/action/notify.h \
+       lttng/action/rotate-session.h \
+       lttng/action/snapshot-session.h \
+       lttng/action/start-session.h \
+       lttng/action/stop-session.h
 
 lttngconditioninclude_HEADERS= \
        lttng/condition/condition.h \
        lttng/condition/buffer-usage.h \
+       lttng/condition/event-rule.h \
        lttng/condition/session-consumed-size.h \
        lttng/condition/session-rotation.h \
        lttng/condition/evaluation.h
@@ -137,6 +143,14 @@ lttngnotificationinclude_HEADERS= \
 lttngtriggerinclude_HEADERS= \
        lttng/trigger/trigger.h
 
+lttngeventruleinclude_HEADERS= \
+       lttng/event-rule/event-rule.h \
+       lttng/event-rule/kprobe.h \
+       lttng/event-rule/kretprobe.h \
+       lttng/event-rule/syscall.h \
+       lttng/event-rule/tracepoint.h \
+       lttng/event-rule/uprobe.h
+
 noinst_HEADERS = \
        lttng/snapshot-internal.h \
        lttng/health-internal.h \
@@ -146,6 +160,7 @@ noinst_HEADERS = \
        lttng/action/notify-internal.h \
        lttng/condition/condition-internal.h \
        lttng/condition/buffer-usage-internal.h \
+       lttng/condition/event-rule-internal.h \
        lttng/condition/session-consumed-size-internal.h \
        lttng/condition/evaluation-internal.h \
        lttng/condition/session-rotation-internal.h \
@@ -162,5 +177,11 @@ noinst_HEADERS = \
        lttng/session-internal.h \
        lttng/session-descriptor-internal.h \
        lttng/tracker-internal.h \
+       lttng/event-rule/event-rule-internal.h \
+       lttng/event-rule/kprobe-internal.h \
+       lttng/event-rule/kretprobe-internal.h \
+       lttng/event-rule/uprobe-internal.h \
+       lttng/event-rule/syscall-internal.h \
+       lttng/event-rule/tracepoint-internal.h \
        version.h \
        version.i
This page took 0.024214 seconds and 5 git commands to generate.