SoW-2020-0002: Trace Hit Counters: trigger error reporting integration
[lttng-tools.git] / include / Makefile.am
index 92b5c75bd26c4260b9fe47d2b16973e67988463f..9a7da5f224c40e5d8e68f740040f7a61e08f47db 100644 (file)
@@ -103,6 +103,8 @@ lttnginclude_HEADERS = \
        lttng/channel.h \
        lttng/domain.h \
        lttng/event.h \
+       lttng/event-expr.h \
+       lttng/event-field-value.h \
        lttng/handle.h \
        lttng/session.h \
        lttng/lttng-error.h \
@@ -132,6 +134,7 @@ lttngactioninclude_HEADERS= \
 lttngconditioninclude_HEADERS= \
        lttng/condition/condition.h \
        lttng/condition/buffer-usage.h \
+       lttng/condition/event-rule.h \
        lttng/condition/session-consumed-size.h \
        lttng/condition/session-rotation.h \
        lttng/condition/evaluation.h
@@ -146,7 +149,9 @@ lttngtriggerinclude_HEADERS= \
 lttngeventruleinclude_HEADERS= \
        lttng/event-rule/event-rule.h \
        lttng/event-rule/kprobe.h \
-       lttng/event-rule/syscall.h
+       lttng/event-rule/syscall.h \
+       lttng/event-rule/uprobe.h \
+       lttng/event-rule/tracepoint.h
 
 noinst_HEADERS = \
        lttng/snapshot-internal.h \
@@ -162,6 +167,7 @@ noinst_HEADERS = \
        lttng/action/stop-session-internal.h \
        lttng/condition/condition-internal.h \
        lttng/condition/buffer-usage-internal.h \
+       lttng/condition/event-rule-internal.h \
        lttng/condition/session-consumed-size-internal.h \
        lttng/condition/evaluation-internal.h \
        lttng/condition/session-rotation-internal.h \
@@ -170,7 +176,10 @@ noinst_HEADERS = \
        lttng/endpoint-internal.h \
        lttng/notification/channel-internal.h \
        lttng/channel-internal.h \
+       lttng/domain-internal.h \
        lttng/event-internal.h \
+       lttng/event-expr-internal.h \
+       lttng/event-field-value-internal.h \
        lttng/rotate-internal.h \
        lttng/ref-internal.h \
        lttng/location-internal.h \
@@ -181,5 +190,7 @@ noinst_HEADERS = \
        lttng/event-rule/event-rule-internal.h \
        lttng/event-rule/kprobe-internal.h \
        lttng/event-rule/syscall-internal.h \
+       lttng/event-rule/uprobe-internal.h \
+       lttng/event-rule/tracepoint-internal.h \
        version.h \
        version.i
This page took 0.024194 seconds and 5 git commands to generate.